Installation von Tumbleweed mit Festplattenverschlüsselung

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Installation von Tumbleweed mit Festplattenverschlüsselung gibt es 5 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Installation von Tumbleweed mit Festplattenverschlüsselung

    Hallo,

    ich versuche seit einigen Tagen, Tumbleweed (Snapshot 20190428) auf einem Notebook zu installieren.



    Die Installation läuft, bei den Partitionseinstellungen lasse ich alles unverändert, nur die Option zur Verschlüsselung der Festplatten wird aktiviert und das Passwort wird eingeben.

    Dann läuft die Installation ohne Fehler bis zum Ende durch.

    Nach dem Neustart dann die Abfrage:
    Attemting to decrypt master key...
    Enter passphrase for hd0, gpt2....

    Nach Eingabe dann die Meldung:
    error: access denied.
    error: no such cryptodisk found
    Entering rescue mode...

    Habe die Installation nun schon mehrfach mit verschiedenen Snapshots gemacht, aber immer mit dem selben Fehler.

    Was mache ich falsch?

    Grüße Maik

    Für den Inhalt des Beitrages 133670 haftet ausdrücklich der jeweilige Autor: Maikx5

  • Bei einer vollverschlüsselten Installation ist bei mir das Keyboard-Layout beim ersten Passwort (Grub) English.
    Beim zweiten Passwort ist es dann Deutsch.
    Teste einfach mal das erste PWD, als wäre deine Tastatur English.
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 133671 haftet ausdrücklich der jeweilige Autor: sterun

  • Moin zusammen,

    kann ich von meinem Lappi nicht bestätigen Sterun.
    Ich arbeite auf einem vollverschlüsselten Lappi und meine Tastatur ist immer deutsch, bei beiden Passwörtern.
    Ggf ist bei Maiks Installation aber was schepps gegangen mit dem Layout.


    Maik versuche im Rescue Mode mal Folgendes (zuvor bitte das Tastaturlayout testen wie Sterun angeregt hat, nicht dass Du doch irgendwie englisch drin hast).

    Quellcode

    1. 1. Finde das entsprechende Device:
    2. blkid | grep crypto
    3. 2. Öffne das Device
    4. cryptsetup luksOpen /dev/sd<XX> <benamse die Partition wie Du magst>
    5. --> z.B.: cryptsetup luksOpen /dev/sda4/ crypthome
    6. 3. Mounte das Device/die Partition
    7. mount /dev/mapper/<benamse die Partition wie Du magst> /<wohin>/<soll>/<die Partition>
    8. --> z.B.: mount /dev/mapper/crypthome /mnt
    Alles anzeigen

    Bei Punkt 2 wird Dir ein Passwort abverlangt. Gebe das von Dir bei der Installation Gewählte ein (unter Beachtung des Tastaturlayouts).

    Wenn das funzt, liegts tatsächlich an der Sprache der Tastatur.
    Viele Grüße,
    T.

    Für den Inhalt des Beitrages 133683 haftet ausdrücklich der jeweilige Autor: Tamerlain

  • Hatte den gleichen Fehler wie @Maikx5.
    Also wieder alles platt gemacht, neu gemastert und nach dem ersten Boot schon wieder der selbe Fehler.
    Dann jedoch hatte ich im PWD für Grub einen "_" mit der Shift + "ß" getestet - und es lief.

    Später angemeldet, sofort die PWD's geändert mit:

    cryptsetup luksDump /dev/sdaXYZ
    cryptsetup luksAddKey /dev/sdaXYZ
    cryptsetup luksKillSlot /dev/sdaXYZ

    Jetzt ist es egal, ob DE oder EN Keyboard - nur noch Zeichen, die auf beiden Layouts identisch sind.
    Ist aber schon komisch, dass es so gekommen ist, zumal während der Masterung alles auf DE gestellt wurde.
    Meine Vermutung: Auf Grub-Ebene greifen noch keine Spracheinstellungen.
    Und Standard ist EN.
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 133684 haftet ausdrücklich der jeweilige Autor: sterun

  • Grub2 verwendet 100%ig englisches Layout, das habe ich jüngst im OpenSUSE wiki gelesen, und ist mir schon bei anderer Distro auf die Füße gefallen, weil ich im Installer dt. Layout hatte, aber in Grub2 nicht. § geht nicht so einfach in english

    Für den Inhalt des Beitrages 133686 haftet ausdrücklich der jeweilige Autor: Scytale

  • sterun schrieb:

    Bei einer vollverschlüsselten Installation ist bei mir das Keyboard-Layout beim ersten Passwort (Grub) English.
    Beim zweiten Passwort ist es dann Deutsch.
    Teste einfach mal das erste PWD, als wäre deine Tastatur English.
    Es ist wirklich so. Beim ersten Passwort ist das Keyboard-Layout EN, beim zweiten DE.

    Hätte ich auch selber drauf kommen können.... (müssen)

    Ich danke Euch!

    Für den Inhalt des Beitrages 133696 haftet ausdrücklich der jeweilige Autor: Maikx5