upgrade Leap 15.0 auf 15.1 ohne KDE desktop

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema upgrade Leap 15.0 auf 15.1 ohne KDE desktop gibt es 10 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • upgrade Leap 15.0 auf 15.1 ohne KDE desktop

    Hallo community,

    habe heute einen upgrade von opernSUSE Leap 15.0 auf openSUSE 15.1 (4.12.14-lp151.28.7-default #1) gemäß folgender Anleitung:

    kamarada.github.io/en/2019/05/…opensuse-leap-150-to-151/

    durchgeführt.

    Hat grundsätzlich funktioniert, jedoch habe ich jetzt das Problem, daß das neue System merkwürdigerweise nicht mehr mit KDE desktop startet, sondern

    in einem iceWM Fenstermanager.

    Ebenso merkwürdig ist das in der Konsole nicht mehr mir Strg + Umschalt + C kopieren bzw. Strg + Umschalt + V einfügen funktioniert.

    Was ist hier passiert und wie kann ich den KDE desktop wiederbekommen?

    Für den Inhalt des Beitrages 133968 haftet ausdrücklich der jeweilige Autor: bruce

  • zypper lr -d

    ergibt

    Brainfuck-Quellcode

    1. # | Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ | URI | Dienst
    2. --+-------------+---------------------------+-----------+-----------------+----------------+-----------+--------+---------------------------------------------------------------+-------
    3. 1 | repo-oss | openSUSE-Leap-15.1-Oss | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/oss/ |
    4. 2 | repo-update | openSUSE-Leap-15.1-Update | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/leap/15.1/oss/ |

    zypper if -t pattern kde kde_plasma

    ergibt


    Brainfuck-Quellcode

    1. Repository-Daten werden geladen...
    2. Installierte Pakete werden gelesen...
    3. Informationen zu Schema kde:
    4. ----------------------------
    5. Repository : openSUSE-Leap-15.1-Oss
    6. Name : kde
    7. Version : 20181130-lp151.1.1
    8. Arch : noarch
    9. Anbieter : openSUSE
    10. Installiert : Nein
    11. Sichtbar für den Benutzer : Ja
    12. Zusammenfassung : KDE-Anwendungen und Plasma 5 Desktop
    13. Beschreibung :
    14. Pakete, die die Plasma Desktopumgebung und Anwendungen von KDE bereit stellen.
    15. Inhalt :
    16. S | Name | Typ | Abhängigkeit
    17. --+-----------------------------+---------+-------------
    18. | patterns-kde-kde | package | Benötigt
    19. | patterns-kde-kde_plasma | package | Benötigt
    20. i | MozillaFirefox | package | Empfohlen
    21. i | ark | package | Empfohlen
    22. i | avahi | package | Empfohlen
    23. i | discover | package | Empfohlen
    24. | dolphin | package | Empfohlen
    25. | gwenview5 | package | Empfohlen
    26. i | kate | package | Empfohlen
    27. i | kcalc | package | Empfohlen
    28. i | kipi-plugins | package | Empfohlen
    29. i | konsole | package | Empfohlen
    30. i | okular | package | Empfohlen
    31. i | patterns-desktop-multimedia | package | Empfohlen
    32. i | patterns-games-games | package | Empfohlen
    33. i | patterns-kde-kde_internet | package | Empfohlen
    34. | patterns-kde-kde_pim | package | Empfohlen
    35. i | patterns-kde-kde_utilities | package | Empfohlen
    36. i | patterns-kde-kde_yast | package | Empfohlen
    37. i | patterns-office-office | package | Empfohlen
    38. i | skanlite | package | Empfohlen
    39. i | spectacle | package | Empfohlen
    40. i | yast2-control-center-qt | package | Empfohlen
    41. Informationen zu Schema kde_plasma:
    42. -----------------------------------
    43. Repository : openSUSE-Leap-15.1-Oss
    44. Name : kde_plasma
    45. Version : 20181130-lp151.1.1
    46. Arch : noarch
    47. Anbieter : openSUSE
    48. Installiert : Nein
    49. Sichtbar für den Benutzer : Ja
    50. Zusammenfassung : KDE Plasma 5 Desktop Basis
    51. Beschreibung :
    52. Basis-Pakete für die KDE Plasma 5 Desktopumgebung.
    53. Inhalt :
    54. S | Name | Typ | Abhängigkeit
    55. ---+------------------------------+---------+-------------
    56. i | breeze5-cursors | package | Benötigt
    57. i | breeze5-decoration | package | Benötigt
    58. i | breeze5-icons | package | Benötigt
    59. i | breeze5-style | package | Benötigt
    60. i | desktop-data-openSUSE | package | Benötigt
    61. i+ | patterns-base-x11 | package | Benötigt
    62. | patterns-kde-kde_plasma | package | Benötigt
    63. | plasma5-session | package | Benötigt
    64. i | polkit-default-privs | package | Benötigt
    65. i | xdg-user-dirs | package | Benötigt
    66. i | alsa-plugins-pulse | package | Empfohlen
    67. | baloo5-file | package | Empfohlen
    68. | baloo5-kioslaves | package | Empfohlen
    69. | baloo5-tools | package | Empfohlen
    70. i | bluedevil5 | package | Empfohlen
    71. i | breeze5-wallpapers | package | Empfohlen
    72. | dolphin | package | Empfohlen
    73. | ffmpegthumbs | package | Empfohlen
    74. i | kde-print-manager | package | Empfohlen
    75. i | kdeconnect-kde | package | Empfohlen
    76. i | kdegraphics-thumbnailers | package | Empfohlen
    77. i | kdenetwork4-filesharing | package | Empfohlen
    78. i | kgamma5 | package | Empfohlen
    79. i | khelpcenter5 | package | Empfohlen
    80. i | kio-extras5 | package | Empfohlen
    81. i | kwalletmanager5 | package | Empfohlen
    82. i | phonon4qt5-backend-gstreamer | package | Empfohlen
    83. i | pinentry-qt5 | package | Empfohlen
    84. i | plasma-nm5 | package | Empfohlen
    85. | plasma5-addons | package | Empfohlen
    86. i | plasma5-pa | package | Empfohlen
    87. i | plasma5-pk-updates | package | Empfohlen
    88. | plasma5-session-wayland | package | Empfohlen
    89. i | pulseaudio | package | Empfohlen
    90. i | pulseaudio-module-x11 | package | Empfohlen
    91. i | pulseaudio-module-zeroconf | package | Empfohlen
    92. i | pulseaudio-utils | package | Empfohlen
    93. i | sddm | package | Empfohlen
    Alles anzeigen
    ... und wie ich hier sehe ist KDE nicht installiert.

    Ich frage mich an dieser Stelle wie das sein kann, da KDE vor dem upgrade von Leap 15.0 installiert war...

    Upgrade ist dann wohl gescheitert.

    Was kann ich nun tun?

    Gibt es eine rollback Möglichkeit??

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von bruce ()

    Für den Inhalt des Beitrages 133982 haftet ausdrücklich der jeweilige Autor: bruce

  • Habe den Befehl

    zypper in -t pattern kde kde_plasma

    mal testweise in der xterm Konsole eingegeben:

    Quellcode

    1. Repository-Daten werden geladen...
    2. Installierte Pakete werden gelesen...
    3. Paketabhängigkeiten werden aufgelöst...
    4. Die folgenden 73 NEUEN Pakete werden installiert:
    5. akonadi-import-wizard akonadi-import-wizard-lang akonadi-plugin-calendar akonadi-plugin-contacts akonadi-plugin-kalarmcal akonadi-plugin-mime akregator akregator-lang baloo5-file baloo5-file-lang baloo5-imports baloo5-imports-lang baloo5-kioslaves baloo5-kioslaves-lang baloo5-tools baloo5-tools-lang dolphin ffmpegthumbs ffmpegthumbs-lang gwenview5 gwenview5-lang kaddressbook kaddressbook-lang kdepim-addons kdepim-addons-lang kdepim-runtime kdepim-runtime-lang kinfocenter5 kinfocenter5-lang kmail kmail-lang kontact kontact-lang korganizer korganizer-lang kpkpass ktnef ktnef-lang libcfitsio6 libKF5MailCommon5 libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPITasks5 libKPimImportWizard5 libKPimItinerary5 libKPimItinerary5-lang libKPimPkPass5 libksieve libksieve-lang mbox-importer mbox-importer-lang messagelib messagelib-lang patterns-kde-kde patterns-kde-kde_imaging patterns-kde-kde_pim patterns-kde-kde_plasma pim-data-exporter pim-data-exporter-lang pim-sieve-editor pim-sieve-editor-lang plasma5-addons plasma5-addons-lang plasma5-desktop plasma5-desktop-lang plasma5-session plasma5-session-wayland plasma5-workspace plasma5-workspace-branding-openSUSE plasma5-workspace-lang plasma-browser-integration plasma-browser-integration-lang xf86-input-synaptics
    6. Die folgenden 4 NEUEN Schemata werden installiert:
    7. kde kde_imaging kde_pim kde_plasma
    8. Die folgenden 44 empfohlenen Pakete wurden automatisch gewählt:
    9. akonadi-import-wizard akonadi-import-wizard-lang akregator akregator-lang baloo5-file baloo5-file-lang baloo5-imports-lang baloo5-kioslaves baloo5-kioslaves-lang baloo5-tools baloo5-tools-lang dolphin ffmpegthumbs ffmpegthumbs-lang gwenview5 gwenview5-lang kaddressbook kaddressbook-lang kdepim-addons-lang kdepim-runtime-lang kinfocenter5-lang kmail kmail-lang kontact kontact-lang korganizer korganizer-lang ktnef libKPimItinerary5-lang libksieve-lang mbox-importer mbox-importer-lang messagelib-lang patterns-kde-kde_pim pim-data-exporter pim-data-exporter-lang pim-sieve-editor pim-sieve-editor-lang plasma5-addons plasma5-addons-lang plasma5-desktop-lang plasma5-session-wayland plasma5-workspace-lang xf86-input-synaptics
    10. 73 neue Pakete zu installieren.
    11. Gesamtgröße des Downloads: 54,2 MiB. Bereits im Cache gespeichert: 0 B. Nach der Operation werden zusätzlich 171,7 MiB belegt.
    12. Fortfahren? [j/n/v/...? zeigt alle Optionen] (j): n
    Alles anzeigen
    Bevor ich was falsch mache:

    Die Installation in der desktop Umgebung in xterm durchführen oder im Textinterface in runlevel 3 vornehmen ?

    Für den Inhalt des Beitrages 133985 haftet ausdrücklich der jeweilige Autor: bruce

  • Feuer frei :)
    Einfach bestätigen (j) und anschl. einen Neustart durchführen, testen und berichten...
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 133986 haftet ausdrücklich der jeweilige Autor: sterun

  • Suuuper!
    Hat einwandfrei geklappt.
    Nach Neustart sieht alles erstmal ok aus.

    Endlich wieder mit bash Konsole!

    Die xterm Konsole hat mich wahnsinnig gemacht, weil ich das copy paste nicht hinbekommen habe.

    @sterun
    Vielen Dank für Deine Hilfe!

    Für den Inhalt des Beitrages 133987 haftet ausdrücklich der jeweilige Autor: bruce

  • Bitte den Beitrag noch als erledigt markieren. Siehe meine Signatur.

    Für den Inhalt des Beitrages 133990 haftet ausdrücklich der jeweilige Autor: Alero