WLAN Problem mit Centrino N 2230 nach Update auf Leap 15.1

Hinweis: In dem Thema WLAN Problem mit Centrino N 2230 nach Update auf Leap 15.1 gibt es 53 Antworten auf 6 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • So, jetzt ist Schluss, ich brauche Hilfe. Nach mehrtätgigen herumdoktern und Foren durchsuchen, ich bekomme das WLAN nicht zum Leben. Bin schon seit Opensuse 11 dabei und hatte hier und da Installationsprobleme mit dem WLAN, die konnte ich aber lösen.


    Situation:

    - Ich habe 2 Ultrabooks Toshiba Portege Z830 und Z930 (nicht mehr ganz neu, aber okay)
    - Habe beide von Leap 42.3 über 15.0 aiuf 15.1 upgedated.
    - Keine Probleme bis auf die Funktion des WLAN vom Z930 Notebook. (Mit Leap 42.x keine Probleme). Ethernet funktioniert.
    - Das Z830 besitzt das Centrino N 6230 WLAN. Das Z930 das Centrino N 2230 WLAN, das macht Probleme. Das Paket "ipw-firmware" für das N 2230 ist installiert.
    - Ich arbeite mit dem NetworkManager
    - Im Network Applet wird kein Wlan-Netz im "Infrastructure-Mode" anfgezeigt (Parallel dazu läuft beim Z830 einwandfrei)
    - Erst beim Einrichten eines Wlan im "Ad-Hoc Mode" (im Network Connection Editor) wird das Wlan meines Routers angezeigt. Nach dem manuellen Connect bleibt es beim "Setting network address" hängen.


    Die letzte Aktion, die ich durchgeführt habe, war das Löschen der Netzwerk-Conigurationen mit "cd /etc/sysconfig/network; ls ifcfg-[earw]* | perl -p -e '{ chomp; `mv $_ $_\.old`; }"
    (Habe ich in einem eurer links gefunden,super) --> Keine Veränderung.
    Was mich wundert, ist, dass "/etc/resolv.conf" leer ist, kein Nameserver-Eintrag, habe ich manuell nachgetragen, keine Veränderung.
    Ausserdem zeigt "journalctl" an, dass der Treiber "iwlwifi" verwendet wird. Ist das korrekt? Sollte da nicht der spezielle Firmware-Treiber stehen?


    Danke für jede Hilfe


    PS: Benutze KDE



    Dmesg nach dem Connect im Ad-Hoc-Modus:


    Für den Inhalt des Beitrages 139270 haftet ausdrücklich der jeweilige Autor: cjm

  • Schon versucht (als Root mit su):

    Code
    rm /etc/resolv.conf

    Und anschl. (als Root mit su):

    Code
    netconfig update -f

    Für den Inhalt des Beitrages 139271 haftet ausdrücklich der jeweilige Autor: sterun

  • Ja, schon versucht, keine Veränderung und "/etc/resolv.conf" bleibt leer.

    Für den Inhalt des Beitrages 139272 haftet ausdrücklich der jeweilige Autor: cjm

  • Netzwerkprobleme:Hilfe bei der Fehlersuche


    Führe das Script bitte aus und poste das Ergebnis.

  • Script "collectNWData" ausgeführt und Output angehängt.


    CND0490E deutet auf falschen Treiber ??

    Dateien

    Für den Inhalt des Beitrages 139277 haftet ausdrücklich der jeweilige Autor: cjm

  • Code
    21: USB 00.0: 0291 USB Host-to-Host link
    Model: "TP-Link M7310"
    Vendor: usb 0x2357 "TP-Link"
    Device: usb 0x0005 "M7310"
    Driver: "rndis_host"
    Driver Modules: "rndis_host"
    Device File: usb0
    Link detected: yes
    Driver Status: rndis_host is active
    Driver Activation Cmd: "modprobe rndis_host"

    Was ist dies (bei hwinfo)?

  • Für den Inhalt des Beitrages 139287 haftet ausdrücklich der jeweilige Autor: cjm

  • i+ | kernel-default | package | 4.12.14-lp150.12.82.1 | x86_64 | (System Packages)

    Den würde ich mal löschen und dafür den ersten aus Leap 15.1 installieren, kannst du an lp151 sehen.:

    Code
    v | kernel-default | Paket | 4.12.14-lp151.28.36.1 | x86_64 | OSS-Update
    v | kernel-default | Paket | 4.12.14-lp151.28.32.1 | x86_64 | OSS-Update
    v | kernel-default | Paket | 4.12.14-lp151.28.25.1 | x86_64 | OSS-Update
    v | kernel-default | Paket | 4.12.14-lp151.28.20.1 | x86_64 | OSS-Update
    v | kernel-default | Paket | 4.12.14-lp151.28.16.1 | x86_64 | OSS-Update
    v | kernel-default | Paket | 4.12.14-lp151.28.13.1 | x86_64 | OSS-Update
    v | kernel-default | Paket | 4.12.14-lp151.28.10.1 | x86_64 | OSS-Update
    v | kernel-default | Paket | 4.12.14-lp151.28.7.1 | x86_64 | OSS-Update
    v | kernel-default | Paket | 4.12.14-lp151.28.4.1 | x86_64 | OSS-Update
    v | kernel-default | Paket | 4.12.14-lp151.27.3 | x86_64 | OSS


    PS bei mir läuft kernel:stable, deswegen ein v in der ersten Spalte.
    Ich meine eine von den beiden:

    Code
    v | kernel-default | Paket | 4.12.14-lp151.28.4.1 | x86_64 | OSS-Update
    v | kernel-default | Paket | 4.12.14-lp151.27.3 | x86_64 | OSS
  • Okay, habe den lp150,,, rausgeschmissen.


    "zypper se -si kernel firmware" zeigt nun:

    Code
    linux-m1yd:~ # zypper se -si kernel firmware
    Loading repository data...
    Reading installed packages...
    S | Name | Type | Version | Arch | Repository
    ---+-----------------+---------+-----------------------+--------+-----------------------
    i+ | ipw-firmware | package | 9-lp151.2.1 | noarch | Main Repository
    i+ | kernel-default | package | 4.12.14-lp151.28.36.1 | x86_64 | Main Update Repository
    i | kernel-firmware | package | 20191118-lp151.2.9.1 | noarch | Main Update Repository

    Für den Inhalt des Beitrages 139292 haftet ausdrücklich der jeweilige Autor: cjm