WLAN Problem mit Centrino N 2230 nach Update auf Leap 15.1

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema WLAN Problem mit Centrino N 2230 nach Update auf Leap 15.1 gibt es 50 Antworten auf 6 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • WLAN Problem mit Centrino N 2230 nach Update auf Leap 15.1

    So, jetzt ist Schluss, ich brauche Hilfe. Nach mehrtätgigen herumdoktern und Foren durchsuchen, ich bekomme das WLAN nicht zum Leben. Bin schon seit Opensuse 11 dabei und hatte hier und da Installationsprobleme mit dem WLAN, die konnte ich aber lösen.

    Situation:

    - Ich habe 2 Ultrabooks Toshiba Portege Z830 und Z930 (nicht mehr ganz neu, aber okay)
    - Habe beide von Leap 42.3 über 15.0 aiuf 15.1 upgedated.
    - Keine Probleme bis auf die Funktion des WLAN vom Z930 Notebook. (Mit Leap 42.x keine Probleme). Ethernet funktioniert.
    - Das Z830 besitzt das Centrino N 6230 WLAN. Das Z930 das Centrino N 2230 WLAN, das macht Probleme. Das Paket "ipw-firmware" für das N 2230 ist installiert.
    - Ich arbeite mit dem NetworkManager
    - Im Network Applet wird kein Wlan-Netz im "Infrastructure-Mode" anfgezeigt (Parallel dazu läuft beim Z830 einwandfrei)
    - Erst beim Einrichten eines Wlan im "Ad-Hoc Mode" (im Network Connection Editor) wird das Wlan meines Routers angezeigt. Nach dem manuellen Connect bleibt es beim "Setting network address" hängen.

    Die letzte Aktion, die ich durchgeführt habe, war das Löschen der Netzwerk-Conigurationen mit "cd /etc/sysconfig/network; ls ifcfg-[earw]* | perl -p -e '{ chomp; `mv $_ $_\.old`; }"
    (Habe ich in einem eurer links gefunden,super) --> Keine Veränderung.
    Was mich wundert, ist, dass "/etc/resolv.conf" leer ist, kein Nameserver-Eintrag, habe ich manuell nachgetragen, keine Veränderung.
    Ausserdem zeigt "journalctl" an, dass der Treiber "iwlwifi" verwendet wird. Ist das korrekt? Sollte da nicht der spezielle Firmware-Treiber stehen?

    Danke für jede Hilfe

    PS: Benutze KDE

    Quellcode

    1. ifconfig
    2. linux-m1yd:~ # hwinfo --wlan
    3. 11: PCI 200.0: 0282 WLAN controller
    4. [Created at pci.386]
    5. Unique ID: y9sn.f2491j44hr8
    6. Parent ID: hoOk.jiG6PzALhq9
    7. SysFS ID: /devices/pci0000:00/0000:00:1c.2/0000:02:00.0
    8. SysFS BusID: 0000:02:00.0
    9. Hardware Class: network
    10. Model: "Intel Centrino Wireless-N 2230 BGN"
    11. Vendor: pci 0x8086 "Intel Corporation"
    12. Device: pci 0x0887 "Centrino Wireless-N 2230"
    13. SubVendor: pci 0x8086 "Intel Corporation"
    14. SubDevice: pci 0x4062 "Centrino Wireless-N 2230 BGN"
    15. Revision: 0xc4
    16. Driver: "iwlwifi"
    17. Driver Modules: "iwlwifi"
    18. Device File: wlan0
    19. Features: WLAN
    20. Memory Range: 0xe0400000-0xe0401fff (rw,non-prefetchable)
    21. IRQ: 28 (no events)
    22. HW Address: 32:0e:15:58:31:4a
    23. Permanent HW Address: 60:36:dd:0a:5a:cd
    24. Link detected: no
    25. WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13
    26. WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472
    27. WLAN encryption modes: WEP40 WEP104 TKIP CCMP
    28. WLAN authentication modes: open sharedkey wpa-psk wpa-eap
    29. Module Alias: "pci:v00008086d00000887sv00008086sd00004062bc02sc80i00"
    30. Driver Info #0:
    31. Driver Status: iwlwifi is active
    32. Driver Activation Cmd: "modprobe iwlwifi"
    33. Config Status: cfg=no, avail=yes, need=no, active=unknown
    34. Attached to: #7 (PCI bridge)
    Alles anzeigen

    Dmesg nach dem Connect im Ad-Hoc-Modus:

    Quellcode

    1. linux-m1yd:~ # dmesg
    2. [14190.066178] iwlwifi 0000:02:00.0: Radio type=0x2-0x0-0x0
    3. [14190.349194] iwlwifi 0000:02:00.0: Radio type=0x2-0x0-0x0
    4. [14190.410263] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    5. [14192.938270] wlan0: Trigger new scan to find an IBSS to join
    6. [14196.874253] wlan0: Trigger new scan to find an IBSS to join
    7. [14198.858214] wlan0: Creating new IBSS network, BSSID 5a:e5:d8:d3:c6:65
    8. [14198.860251] iwlwifi 0000:02:00.0: Unable to find TIM Element in beacon
    9. [14198.861124] iwlwifi 0000:02:00.0: Unable to find TIM Element in beacon
    10. [14198.861259] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    11. [14232.617896] wlan0: No active IBSS STAs - trying to scan for other IBSS networks with same SSID (merge)
    12. [14244.165168] iwlwifi 0000:02:00.0: Radio type=0x2-0x0-0x0
    13. [14244.439685] iwlwifi 0000:02:00.0: Radio type=0x2-0x0-0x0
    14. [14244.502874] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    15. [14244.531250] iwlwifi 0000:02:00.0: Radio type=0x2-0x0-0x0
    16. [14244.810633] iwlwifi 0000:02:00.0: Radio type=0x2-0x0-0x0
    17. [14244.874781] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    Alles anzeigen

    Für den Inhalt des Beitrages 139270 haftet ausdrücklich der jeweilige Autor: cjm

  • opensuse-forum.de/thread/1312-…ilfe-bei-der-fehlersuche/

    Führe das Script bitte aus und poste das Ergebnis.

    Für den Inhalt des Beitrages 139276 haftet ausdrücklich der jeweilige Autor: Alero

  • Script "collectNWData" ausgeführt und Output angehängt.

    CND0490E deutet auf falschen Treiber ??
    Dateien
    • collectNWData.txt

      (18,04 kB, 7 mal heruntergeladen, zuletzt: )

    Für den Inhalt des Beitrages 139277 haftet ausdrücklich der jeweilige Autor: cjm

  • Quellcode

    1. 21: USB 00.0: 0291 USB Host-to-Host link
    2. Model: "TP-Link M7310"
    3. Vendor: usb 0x2357 "TP-Link"
    4. Device: usb 0x0005 "M7310"
    5. Driver: "rndis_host"
    6. Driver Modules: "rndis_host"
    7. Device File: usb0
    8. Link detected: yes
    9. Driver Status: rndis_host is active
    10. Driver Activation Cmd: "modprobe rndis_host"
    Was ist dies (bei hwinfo)?
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 139282 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Brainfuck-Quellcode

    1. linux-m1yd:~ # zypper se -si kernel firmware
    2. Loading repository data...
    3. Reading installed packages...
    4. S | Name | Type | Version | Arch | Repository
    5. ---+-----------------+---------+-----------------------+--------+-----------------------
    6. i+ | ipw-firmware | package | 9-lp151.2.1 | noarch | Main Repository
    7. i+ | kernel-default | package | 4.12.14-lp150.12.82.1 | x86_64 | (System Packages)
    8. i+ | kernel-default | package | 4.12.14-lp151.28.36.1 | x86_64 | Main Update Repository
    9. i | kernel-firmware | package | 20191118-lp151.2.9.1 | noarch | Main Update Repository

    Für den Inhalt des Beitrages 139287 haftet ausdrücklich der jeweilige Autor: cjm

  • cjm schrieb:

    i+ | kernel-default | package | 4.12.14-lp150.12.82.1 | x86_64 | (System Packages)
    Den würde ich mal löschen und dafür den ersten aus Leap 15.1 installieren, kannst du an lp151 sehen.:

    Quellcode

    1. v | kernel-default | Paket | 4.12.14-lp151.28.36.1 | x86_64 | OSS-Update
    2. v | kernel-default | Paket | 4.12.14-lp151.28.32.1 | x86_64 | OSS-Update
    3. v | kernel-default | Paket | 4.12.14-lp151.28.25.1 | x86_64 | OSS-Update
    4. v | kernel-default | Paket | 4.12.14-lp151.28.20.1 | x86_64 | OSS-Update
    5. v | kernel-default | Paket | 4.12.14-lp151.28.16.1 | x86_64 | OSS-Update
    6. v | kernel-default | Paket | 4.12.14-lp151.28.13.1 | x86_64 | OSS-Update
    7. v | kernel-default | Paket | 4.12.14-lp151.28.10.1 | x86_64 | OSS-Update
    8. v | kernel-default | Paket | 4.12.14-lp151.28.7.1 | x86_64 | OSS-Update
    9. v | kernel-default | Paket | 4.12.14-lp151.28.4.1 | x86_64 | OSS-Update
    10. v | kernel-default | Paket | 4.12.14-lp151.27.3 | x86_64 | OSS

    PS bei mir läuft kernel:stable, deswegen ein v in der ersten Spalte.
    Ich meine eine von den beiden:

    Quellcode

    1. v | kernel-default | Paket | 4.12.14-lp151.28.4.1 | x86_64 | OSS-Update
    2. v | kernel-default | Paket | 4.12.14-lp151.27.3 | x86_64 | OSS
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 139288 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Okay, habe den lp150,,, rausgeschmissen.

    "zypper se -si kernel firmware" zeigt nun:

    Brainfuck-Quellcode

    1. linux-m1yd:~ # zypper se -si kernel firmware
    2. Loading repository data...
    3. Reading installed packages...
    4. S | Name | Type | Version | Arch | Repository
    5. ---+-----------------+---------+-----------------------+--------+-----------------------
    6. i+ | ipw-firmware | package | 9-lp151.2.1 | noarch | Main Repository
    7. i+ | kernel-default | package | 4.12.14-lp151.28.36.1 | x86_64 | Main Update Repository
    8. i | kernel-firmware | package | 20191118-lp151.2.9.1 | noarch | Main Update Repository

    Für den Inhalt des Beitrages 139292 haftet ausdrücklich der jeweilige Autor: cjm