Systempartition wird nicht gemountet

Hinweis: In dem Thema Systempartition wird nicht gemountet gibt es 16 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo,
    Ich benutze LEAP !5.1.
    Der Startvorgang läuft nicht zu Ende, ich lande in der Konsole und kann dort mit root Passwort weitermachen...
    Wenn ich mit dem Installationsmedium starte, stoppt YAST und gibt mir die Meldung aus, dass sich die Partition nicht mounten lässt. Wenn ich ihm dann die UUID manuell vorgebe, gibt er die gleiche Meldung aus.
    Ich habe mal die Partition überprüft - scheint soweit in Ordnung zu sein.


    Danke für Eure Antwort.
    Grüße, Gerhard

    Für den Inhalt des Beitrages 141087 haftet ausdrücklich der jeweilige Autor: Gerhard59


  • Die sda 4 ist die richtige. Ich hab das jetzt unter nem anderen system (mint) gemacht

    3 Mal editiert, zuletzt von Gerhard59 ()

    Für den Inhalt des Beitrages 141090 haftet ausdrücklich der jeweilige Autor: Gerhard59

  • Hallo Gerhard,


    zunächst einmal ein paar grundlegende Infos:


    In der Konsole kann man auf zwei verschiedene Arten und Weisen arbeiten: einmal als normaler User - dann braucht man auch kein Passwort eingeben, oder als root - dann wird ein Passwort verlangt.


    Unter Startmenü > System findet man einmal das Programm Konsole, das ist ohne Anmeldung und einmal Terminal - Superusermodus.
    Man kann aber auch in der Konsole dauerhaft root-Privilegien erlangen, indem man das Kommando su und anschließend das Passwort eingibt.
    Für einen einzelnen Befehl, der als root ausgeführt werden soll, gibt es den Befehl sudo, der dem eigentlichen Befehl voran gestellt wird (sudo befehl). Allerdings ist bei openSUSE su vorzuziehen.


    Damit die Konsolenausgaben hier im Forum auch lesbar sind, gibt es im Editor die Funktion Code </>. Findet man oben in der Funktionsleiste als vierte Position von rechts. In das sich öffnende Fenster werden dann einfach die Daten rein kopiert.


    Damit wir auch sehen, was dein Rechner wirklich ausgibt, ist es sinnvoll, auch die eingegebenen Befehle zu kopieren. Nur so lässt sich nachvollziehen, welche Befehle ausgeführt wurden.



    Die Ausgabe, um die ich dich gebeten hatte, würde bei mir also so aussehen:



    Beste Grüße,
    Stephan

    Für den Inhalt des Beitrages 141092 haftet ausdrücklich der jeweilige Autor: Forentroll

  • Hallo Stephan,
    vielen Dank für Deine Geduld. Hier also nochmal 2. Versuch.


    Gute Nacht, ich muss morgen Abend weitermachen

    Für den Inhalt des Beitrages 141093 haftet ausdrücklich der jeweilige Autor: Gerhard59

  • Hallo Gerhard,


    wenn du diese Befehle unter Linux Mint ausführst, wird auch lediglich die Situation unter Linux Mint wiedergegeben. Da du ja geschrieben hattest, dass du unter openSUSE in der root-Konsole landest, wäre es sicherlich sinnvoll, sich die Ausgabe von dort zu holen. Nur dann wird beispielsweise /sda4 auch als Stammlaufwerk bezeichnet werden.



    Beste Grüße,
    Stephan

    Für den Inhalt des Beitrages 141095 haftet ausdrücklich der jeweilige Autor: Forentroll

  • Hallo Stephan, hier das Ergebnis. Ich hab das Ding durch Umleitung in ein File erzeugt, deswegen fehlt die oberste Zeile mit dem Befehl.

    Für den Inhalt des Beitrages 141120 haftet ausdrücklich der jeweilige Autor: Gerhard59

  • Moinsen zämme,


    als erstes _welche_ Partition lässt sich nicht mounten?
    Als 2. was steht in der fstab dazu (cat /etc/fstab)?


    Wenn Du in der Rescue Shell bist, mount -o remount,rw /.
    Danach mount -a und den Fehler posten wenn einer auftauchen sollte.


    Wenn es /home ist, was sich nicht mounten lässt (was ich fast annehme *hüstel*), Kommentiers in der fstab aus - mach einen Lattenzaun vor den Mountbefehl (sprich kommentier die betreffende Zeile aus) und dann reboot.
    Dann sollte das System hochkommen und Du kannst bei hochgefahrenem System debuggen - was die Sache sehr viel einfacher macht.


    Merke Dir aber den Rootlogin (das Passwort), denn wenn /home nicht gemounted wird, kannste Dich nur mit dem am System anmelden. Schau auch dass der rootlogin an der grafischen Console erlaubt ist.

    Viele Grüße,
    T.

    Für den Inhalt des Beitrages 141123 haftet ausdrücklich der jeweilige Autor: Tamerlain

  • Also hier mal die Ergebnisse:
    cat /proc/cmdline

    Code
    BOOT_IMAGE=/boot/vmlinuz-4.12.14-lp151.28.40-default root=UUID=72dd9ea3-b8ad-4fe6-ba39-155be77b76d9 splash=silent resume=/dev/disk/by-uuid/0f648572-3984-4359-93ea-f4cd0e96c35e quiet splash=silent resume=/dev/disk/by-uuid/0f648572-3984-4359-93ea-f4cd0e96c35e quiet mitigations=auto


    Und hier fdisk -l:





    In der fstab steht:


    Code
    UUID=72dd9ea3-b8ad-4fe6-ba39-155be77b76d9 / ext4 acl,user_xattr 0 1
    UUID=64d48245-9fd9-47cc-b731-a3f372d88b09 /srv ext4 data=ordered,acl,user_xattr 0 2
    UUID=9a662a97-92e9-4aad-9e63-f71af135709f /home xfs defaults 0 0
    UUID=397E-2059 /boot/efi vfat defaults 0 0
    UUID=33DE-7923 /tmp vfat iocharset=utf8 0 0

    Bei Deiner (Tamerlein) empfohlenen Vorgehensweise "Wenn Du in der Rescue Shell bist, mount -o remount,rw /.
    Danach mount -a und den Fehler posten wenn einer auftauchen sollte."
    kam als Ergebnis bei "mount -a" (konnte ich aber leider nicht in ein File umleiten):
    mount: /tmp: UUID=33DE-7923
    Das home Verzeichnis ist meines Erachtens nicht das Problem, ich konnte die files ja auch ins home schreiben.

    Einmal editiert, zuletzt von Gerhard59 ()

    Für den Inhalt des Beitrages 141127 haftet ausdrücklich der jeweilige Autor: Gerhard59