Windows-10-Partition beschädigt!

Hinweis: In dem Thema Windows-10-Partition beschädigt! gibt es 8 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Habe eigentlich seit Jahr und Tag auf meinem Desktop neben Tumbleweed Windows 10 installiert. Benötige das wegen Dragon Naturally Speaking. Kann es aber seit etwa drei Jahren nicht mehr öffnen, weil ich an der Partition rumgefummelt habe! Es war wo, dass vor der Systempartition noch eine leere Partition lag, die ich unbedingt loswerden wollte. Also löschte ich sie, sodass die Windows-Partition nicht mehr am Anfang der Festplatte steht, sondern erst ab Datenblock 2048 steht. Daher lässt sich Windows nicht mehr starten. Hat jemand eine Idee, wie man das reparieren kann? Die Überlegung war, die Partition von 0 bis 2048 wiederherzustellen. Nur: Wie geht das unter Yast?

    Für den Inhalt des Beitrages 278579 haftet ausdrücklich der jeweilige Autor: matbhm

  • Für den Inhalt des Beitrages 278599 haftet ausdrücklich der jeweilige Autor: matbhm

  • Irgendwie alles Mist. Früher habe ich mich mit alledem noch ausgekannt. Inzwischen irgendwie alles verloren gegangen.


    Für den Inhalt des Beitrages 278608 haftet ausdrücklich der jeweilige Autor: matbhm

  • Ist Windows 10 denn im Boot-Menü noch zu sehen?

    Code
    grub2-once --list

    oder

    Code
    efibootmgr --verbose

    ...sollte die Auswahl-Menüs zeigen.


    Ich würde es erstmal mit der einfachsten Methode versuchen.

    Yast - Bootloader - Bootloader-Optionen - Häkchen setzen bei "Fremdes OS testen" (bzw. kontrollieren) aber noch nicht mit "ok" speichern.

    Unter Bootcode-Optionen...

    Dort sollte vermutlich "Grub2 für EFI" stehen - das einmal ändern, ohne zu speichern und gleich wieder rückgängig machen (so, dass der Eintrag zu sehen ist, welcher auch vorher schon drin war) und dann mit "ok" speichern.

    Der Bootloader wird dann neu geschrieben und mit etwas (viel) Glück kannst du W10 wieder starten.


    Ich selbst meide Dual-Boot (nur VM), da die Gefahr einfach zu groß ist, dass nichts mehr startet.

    Deswegen ggf. mit Clonezilla ein Image deiner Platte(n) erstellen.

    Für den Inhalt des Beitrages 278610 haftet ausdrücklich der jeweilige Autor: sterun

  • Jo, Windows10 ist im Menü zu sehen. Und Yast - Bootloader - Bootloader-Optionen - Fremdes OS testen hilft nix. Aber vielen Dank! Sämtliche Reparaturversuche über Windows scheiterten auch! Es ist einfach so, dass, wer Windows starten will, Windows immer an Anfang einer Partition stehen haben muss! Und dadurch, dass ich die winzige Partition vor der Windows-Start-Partition mit selbiger verschmolzen habe, steht Windows nicht mehr am Anfang der Partition.


    Code
    linux-xxxx:~ # grub2-once --list
    0 openSUSE Tumbleweed
    1 Advanced options for openSUSE Tumbleweed>openSUSE Tumbleweed, with Linux 5.6.2-1-default
    2 Advanced options for openSUSE Tumbleweed>openSUSE Tumbleweed, with Linux 5.6.2-1-default (recovery mode)
    3 Advanced options for openSUSE Tumbleweed>openSUSE Tumbleweed, with Linux 5.5.13-1-default
    4 Advanced options for openSUSE Tumbleweed>openSUSE Tumbleweed, with Linux 5.5.13-1-default (recovery mode)
    5 Windows Boot Manager (on /dev/sdb2)
    linux-xxxx:~ #


    Für den Inhalt des Beitrages 278611 haftet ausdrücklich der jeweilige Autor: matbhm

  • Du hast offensichtlich eine Partition von Windows gelöscht. Normal legt Windows 4 Partitionen an. Die erste Partition auf einer UEFI-Festplatte beginnt immer beim Block 2048. Davor ist die GUID Partitionstabelle kurz GPT.


    Bei Dir fehlt die Microsoft reservierte Partition. Ist das die gelöschte Partition? Der Zweck dieser Partition ist mir und auch vielen anderen nicht bekannt. Das es den Windows Bootmanager gibt, würde ich einen Start mit Supergrub versuchen.

    Einmal editiert, zuletzt von tuxpapa ()

    Für den Inhalt des Beitrages 278620 haftet ausdrücklich der jeweilige Autor: tuxpapa

  • So schaut es bei mir aus:


    Für den Inhalt des Beitrages 278621 haftet ausdrücklich der jeweilige Autor: tuxpapa