Probleme mit xrdp bei openSUSE Leap 15.2

Hinweis: In dem Thema Probleme mit xrdp bei openSUSE Leap 15.2 gibt es 10 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo
    Ich bekomme auf einer frischen openSUSE Leap 15.2-Installation xrdp nicht zum Laufen. Die Installation ähnelt sehr stark meiner mit xrdp funktionierenden Leap 15.1- Installation.

    Kurzbeschreibung der installierten Maschine: Leap 15.2 mit KDE Plasma Desktop, vom DVD-Medium inkl. Netzwerk-Repositories, keine speziellen Optionen gewählt = out of the Box-Default, Installation in einen Hyper-V-Gast mit zwei CPUs und 2GB RAM, Generation 2 Hyper-V-Gast, lokales Netzwerk transparent vorhanden via virtuellen Switch (ohne NAT/Default-Switch o.ä.)

    Nach der Installation habe ich via Yast die Pakete für xrdp installiert, den Dienst gestartet und "enabled" (*) sowie den TCP-Port 3389 freigegeben. Nun kann ich mit einem RDP-Client auf xrdp verbinden, nach Eingabe der Credentials erhalte ich im Fall von XVNC die Fehlermeldung (siehe png-Anhang) oder die RDP-Session schmiert ab (XORG). Was mach ich falsch? Bei meiner Leap 15.1-Maschine (auch auf einer Hyper-V) läuft alles anstandslos. xrdp-Installation und Aktivierung erfolgten auf die gleiche Art und Weise. Die neue Maschine mit Leap 15.2 läuft bisher auch problemlos bis auf xrdp. Meine bisherigen Suchen haben mich noch zu keiner Lösung geführt.

    *)

    sudo systemctl enable xrdp

    sudo systemctl start xrdp



    Gruß
    knuffel007

    Für den Inhalt des Beitrages 281984 haftet ausdrücklich der jeweilige Autor: knuffel007

  • Hallo knuffel007


    Firewall mal testweise abgeschaltet mit:

    Code
    systemctl stop firewalld.service

    ...schon probiert?

    Für den Inhalt des Beitrages 281997 haftet ausdrücklich der jeweilige Autor: sterun

  • Hallo zusammen,

    nach einem Upgrade von 15.1 zu 15.2 erhalte ich die gleiche Meldung bei xvnc. xorg schmiert ab. Bin um jeden Tip dankbar.


    MfG

    Werner

    Für den Inhalt des Beitrages 281998 haftet ausdrücklich der jeweilige Autor: WBrand

  • WBrand

    Eröffne für dein Problem bitte einen eigenen Beitrag! Siehe auch ---> Wichtig:Vor dem Posten bitte erst Lesen!

  • Hallo

    Ich habe die Firewall einmal testweise, wie von sterun beschrieben, abgeschaltet. Der Versuch, eine RDP-Session via xrdp zu öffnen, führt zum gleichen Ergebnis wie vorher: gleiche Fehlermeldung bei Wahl von xvnc bzw. Session schmiert ab, wenn xorg gewählt wurde.

    Hat jemand eine andere, eventuell hilfreiche Idee?

    Kann ich irgendwelche zielführenden Logfiles beifügen? Wenn ja, dann spezifiziert diese bitte möglichst mit vollständigem Pfad.

    Vielen Dank und Gruß

    knuffel007

    Für den Inhalt des Beitrages 282003 haftet ausdrücklich der jeweilige Autor: knuffel007

  • Hallo zusammen
    Ich gehe in meiner Fragestellung zu dem von mir geschilderten Problem noch einen Schritt weiter. Da meine Installationsvariante ziemlich gute einem Default-Setup eines KDE-Plasma Desktops ohne irgendwelche Spezialitäten entspricht, stellt sich mir die Frage: Gibt es jemanden, der in einer vergleichbaren Konstellation (xrdp unter Leap 15.2) derzeit erfolgreich benutzen kann?
    Danke & Gruß
    knuffel007

    Für den Inhalt des Beitrages 282017 haftet ausdrücklich der jeweilige Autor: knuffel007

  • Hallo,


    das selbe Problem tritt unter Leap 15.1 nach der Installation xrdp 0.9.13.1 auch auf, scheint also am xrdp zu liegen.


    Gruß

    ctseps

    Für den Inhalt des Beitrages 282025 haftet ausdrücklich der jeweilige Autor: ctseps

  • Hallo zusammen

    Herzlichen Dank an sterun für den Verweis auf den bugzilla-Eintrag. Demnach ist es ein Problem der /etc/xrdp/startwm.sh , die derzeit in leap 15.2 nur für gnome ausgelegt zu sein scheint.

    Ich habe nun als vorübergehende Lösung, wie es auch im bugzilla-Eintrag vorgeschlagen wird, die /etc/xrdp/startwm.sh durch jene aus meiner leap 15.1 - Installation ersetzt. Dann funktioniert das Öffnen der Sessions in xrdp anstandslos.
    Gruß

    knuffel007

    Für den Inhalt des Beitrages 282038 haftet ausdrücklich der jeweilige Autor: knuffel007

  • In der "startwm.sh" unter /etc/xrdp/ wurde Plasma wohl vergessen.

    Lediglich die Desktopumgebungen "icewm" und "gnome" sind enthalten.

    Unter...

    https://bugzilla.opensuse.org/attachment.cgi?id=839355

    ...sieht man, wie man Plasma nachträglich hinzufügen kann.

    Oder als Workaround, wie du es gemacht hast, die "startwm.sh" aus openSUSE Leap 15.1 verwenden.

    Wenn es jetzt läuft, kannst du diesen Thread als "erledigt" markieren (Doppelklick in das "unerledigt" Kästchen - ganz oben unter deiner Themenüberschrift).

    Für den Inhalt des Beitrages 282040 haftet ausdrücklich der jeweilige Autor: sterun