LO Base: kein SDBC-Treiber für die URL 'sdbc:embedded:firebird'

Hinweis: In dem Thema LO Base: kein SDBC-Treiber für die URL 'sdbc:embedded:firebird' gibt es 22 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo,


    mein Libre-Office kann verschiedene Datenquellen nicht mehr finden, bzw. sich nicht mehr damit verbinden.

    Das ist seit einem Update vor ca. 6 Wochen so... konnte/wollte mich bisher nicht drum kümmern, meist hat sich nicht-mehr-funktionierendes wenige Tage später nach weiteren Updates von selbst gerichtet, hier aber nicht. Und jetzt brauche ich denn doch mal wieder Zugriff auf meine Adressdatenbank.


    Will ich die Datenbank öffnen kommt die Meldung


    Wenn ich hier auf "Mehr" klicke, kommen drei Fehlerdetails:

    Zitat

    Fehler: Verbindungsaufbau gescheitert /home/abuild/rpmbuild/BUILD/libreoffice-7.0.3.1/connectivity/source/commontools/dbtools.cxx:751

    Zitat

    Fehler: SQL-Status: HY000


    Die Verbindung zur externen Datenquelle konnte nicht hergestellt werden. Es wurde kein SDBC-Treiber für die URL 'sdbc:embedded:firebird' gefunden. /home/abuild/rpmbuild/BUILD/libreoffice-7.0.3.1/connectivity/source/commontools/dbexception.cxx:399


    Information: Es wurde eine Verbindung zur URL "sdbc:embedded:firebird" angefordert.

    Versuche ich in LO Calc oder LO Writer, auf die Datenquellen zuzugreifen (Menü-Ansicht-Datenquellen) erscheint die gleiche Fehlermeldung, sobald ich in den Datenquellen Tabellen anwähle. Lediglich die erste Überschrift ist anders, nämlich Die Verbindung zur Datenquelle "Add20" konnte nicht hergestellt werden. Die weiteren Ausgaben sind gleich.

    Die Literatur-Datenbank ist erreichbar. Eine weitere Datenbank namens "EvolutionLocal" liefert einen ähnlichen Fehler, im Detail ist die Fehlerausgabe hier anders:

    Zitat

    Es wurde kein SDBC-Treiber für die URL 'sdbc:address:evolution:local' gefunden.


    Java erscheint installiert und in LO aktiviert zu sein:


    stimmt scheinbar mit der Aktuellen überein:

    Code
    frank@7470tw:~> java -version
    openjdk version "11.0.9.1" 2020-11-04
    OpenJDK Runtime Environment (build 11.0.9.1+1-suse-1.1-x8664)
    OpenJDK 64-Bit Server VM (build 11.0.9.1+1-suse-1.1-x8664, mixed mode)
    frank@7470tw:~>

    Die Ausgaben von zypper se java und zypper se libreoffice sind sehr lang und ich weiß nicht, ob das die richtigen Suchen sind, deshalb poste ich das erst mal nicht.


    Im Netz habe ich Themen zu hsqldb gesehen, die scheint vorhanden:

    ebenso die firebird:

    So weit bin ich nun gekommen, aber ich verstehe hier sehr wenig... ... und möchte nicht einfach rumprobieren und mir noch was zerschießen,


    deshalb hoffe ich auf eure Hilfe. Mit Dank.

    Dell Latitude 7470, 4 x i7 6600U, 32 GB, 1TB NVMe

    Tumbleweed, KDE Plasma

    Für den Inhalt des Beitrages 287611 haftet ausdrücklich der jeweilige Autor: baumkraxler

  • Versuche

    Code
    zypper in -f libreoffice-sdbc-hsqldb

    Edit ... zypper findet nichts ...


    Hast du auch das richtige installiert? 32bit / 64 bit ..

    Alle bisherigen Aussagen lauten: libreoffice-sdbc-hsqldb nicht oder nicht in der richtigen Version installiert ...

  • Oder mal hier fragen ... da sitzen die Spezialisten für OO


    http://oooforum.de/index.php?s…858d9993155bc123489895f18

  • Zitat

    Code

    Code
    7470tw:~ # zypper in -f libreoffice-sdbc-hsqldb
    Retrieving repository 'HW_roccat' metadata ........................................[done]
    Building repository 'HW_roccat' cache .............................................[done]
    Loading repository data...
    Reading installed packages...
    Package 'libreoffice-sdbc-hsqldb' not found.
    Resolving package dependencies...
    Nothing to do.
    7470tw:~ #

    Genau, ich glaube das hatte ich schon probiert.

    Zitat

    Hast du auch das richtige installiert? 32bit / 64 bit ..

    Seit ich TW Ende 2018 installiert habe ist da außer zypper dup nix geschehen. Und bis vor kurzem lief alles weitgehend einwandfrei.

    Zitat

    Oder mal hier fragen ... da sitzen die Spezialisten für OO

    Da bin ich gerade und finde in einem Thread vom 24.10.2020:

    Zitat

    Firebird ist zur Zeit wieder auf den experimentellen Status zurückgefahren. Aktuelle Firebird-Datenbanken funktionieren weiter ohne Auswahl der experimentellen Funktionen. Für neue Datenbanken ist aber das Einschalten notwendig.

    Wurde da in Tumbleweed in letzter Zeit etwas geändert, von HSQLDB auf firebird oder so?

    Wo schalte ich "experimentelle Funktionen" ein oder aus?

    Dell Latitude 7470, 4 x i7 6600U, 32 GB, 1TB NVMe

    Tumbleweed, KDE Plasma

    Für den Inhalt des Beitrages 287615 haftet ausdrücklich der jeweilige Autor: baumkraxler

  • Hallo lieber baumkraxler ,

    Seit ich TW Ende 2018 installiert habe ist da außer zypper dup nix geschehen.

    wirklich ??? ;);)


    Dir ist aber bekannt wie Updates unter Tumbleweed gemacht werden .... :)

    Für den Inhalt des Beitrages 287616 haftet ausdrücklich der jeweilige Autor: Petert

  • Wurde da in Tumbleweed in letzter Zeit etwas geändert, von HSQLDB auf firebird oder so?

    Wo schalte ich "experimentelle Funktionen" ein oder aus?

    Das kann ich leider nicht beantworten, da ich OO nicht nutze ausser dem verfassen eines gelegentlichen Briefes. Sry. Auch mit Datenbanken habe ich leider nichts am Hut.

  • Dir ist aber bekannt wie Updates unter Tumbleweed gemacht werden ....

    äähhh, keine Ahnung was Du meinst (verunsichert...) ... scheinbar nicht?


    Ich habe hier irgendwann mal gelesen, in Tumbleweed immer zypper dup, seitdem mache ich das so, hatte ich aber ja geschrieben, oder was meinst Du???

    Dell Latitude 7470, 4 x i7 6600U, 32 GB, 1TB NVMe

    Tumbleweed, KDE Plasma

    Für den Inhalt des Beitrages 287619 haftet ausdrücklich der jeweilige Autor: baumkraxler

  • Ich habe hier irgendwann mal gelesen, in Tumbleweed immer zypper dup,

    Ist richtig, alles gut ...

  • was ich meine ... nie aufgeräumt ... nie gecleant .. ???


    > kein "ref" kein "clean" ?? nur "# zypperdup" ??

    Für den Inhalt des Beitrages 287621 haftet ausdrücklich der jeweilige Autor: Petert

  • was ich meine ... nie aufgeräumt ... nie gecleant .. ???


    > kein "ref" kein "clean" ?? nur "# zypperdup" ??

    Tja, wohl erwischt, in der Tat...


    ... ich bin ja eigentlich Baumpfleger und habe da eher im Winter mal Zeit, mich weiter in die Materia Linux zu knien.


    Und die ganze Geschichte mit Repo´s und so habe ich noch nicht so tief durchdrungen.


    Finde ich da irgendwo eine Kurzanleitung oder übersichtliche Zusammenfassung?

    Dell Latitude 7470, 4 x i7 6600U, 32 GB, 1TB NVMe

    Tumbleweed, KDE Plasma

    Für den Inhalt des Beitrages 287622 haftet ausdrücklich der jeweilige Autor: baumkraxler