Startdienste verzögern massiv den Bootvorgang

Hinweis: In dem Thema Startdienste verzögern massiv den Bootvorgang gibt es 20 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo zusammen,

    ich habe seit Weihnachten herum das Problem das mein Rechner immer langsamer hoch fährt und ich denke auch das das Netz manchmal irgendwie Probleme macht.

    Erst mal hier ein Auszug der euch etwas helfen könnte:

    Ich hatte da mal Probleme nach irgend einem Update, da war dann plötzlich der Netzwerk Manager am werkeln. Das habe ich dann auch wieder zurück bestellt bekommen ( wenn auch schwer ) aber seit her habe ich die Probleme beim booten.

    Ich wollte das im Yast einfach auf Wicked ändern, neu starten und fertig, dann waren auf einmal Dienste die sich da nicht mehr gestartet haben und sich auch manuell nicht starten liesen. Ich hatte dann einiges Probiert bis ich dann die Wiederherstellung bemüht hatte. Das lief Stunden danach startete der XServer nicht mehr, aber das Netz war wieder auf wicked und durch Updates kam das System wieder in Gang.

    Wo fängt man an zu suchen bei den ersten beiden Diensten die mir eindeutig zu lang erscheinen ?

  • Wo fängt man an zu suchen bei den ersten beiden Diensten die mir eindeutig zu lang erscheinen ?

    :thumbup:

  • Poste doch mal:

    Code
    parted -l
    Code
    systemctl cat btrfsmaintenance-refresh.service
    Code
    grep PERIOD /etc/sysconfig/btrfsmaintenance

    Für den Inhalt des Beitrages 288042 haftet ausdrücklich der jeweilige Autor: sterun



  • Code
    localhost:/home/joerg # grep PERIOD /etc/sysconfig/btrfsmaintenance
    BTRFS_DEFRAG_PERIOD="none"
    BTRFS_BALANCE_PERIOD="weekly"
    BTRFS_SCRUB_PERIOD="monthly"
    BTRFS_TRIM_PERIOD="none"
    localhost:/home/joerg #


    Bitte schön !

    Konnte leider erst jetzt wieder ran.

  • Konnte ebenfalls nicht früher antworten.

    Bevor ich mich für eine Weile ganz zurück ziehe, versuchen wir vorher noch dein Problem zu lösen.

    Postest du noch als Root (su -):

    Code
    systemctl list-units --all btrfsmaintenance-refresh.*

    Für den Inhalt des Beitrages 288114 haftet ausdrücklich der jeweilige Autor: sterun

  • Das wäre natürlich toll, wenn wir da noch zu einer Lösung finden sollten. Hier die Ausgabe :


  • Und noch:

    Code
    systemctl list-unit-files --state enabled | grep -Ei net
    Code
    systemctl status network.service | head -n 12

    Für den Inhalt des Beitrages 288117 haftet ausdrücklich der jeweilige Autor: sterun

  • Bitte schön !

    Code
    localhost:/home/joerg # systemctl list-unit-files --state enabled | grep -Ei net
    dbus-org.opensuse.Network.AUTO4.service enabled
    dbus-org.opensuse.Network.DHCP4.service enabled
    dbus-org.opensuse.Network.DHCP6.service enabled
    dbus-org.opensuse.Network.Nanny.service enabled
    network.service
  • Bzgl. btrfsmaintenance - sieht alles, bis ins Detail, gut aus.

    Was du trotzdem einfach mal testen kannst, ohne, dass wir den Inhalt der Services selbst ändern:

    Code
    systemctl disable btrfsmaintenance-refresh.service
    Code
    systemctl enable btrfsmaintenance-refresh.path

    Hier deaktivieren wir noch LVM-Monitor, da du LVM nicht nutzt:

    Code
    systemctl stop lvm2-monitor
    Code
    systemctl disable lvm2-monitor

    Danach System mal herunterfahren, kurz warten und wieder starten.


    Dann erneut die Ausgabe posten:

    Code
    systemd-analyze blame

    PS: Alles als Root mit User: su -

    Für den Inhalt des Beitrages 288119 haftet ausdrücklich der jeweilige Autor: sterun