Blu-ray-Laufwerk liefert I/O error trotz einwandfreier Hardware

Hinweis: In dem Thema Blu-ray-Laufwerk liefert I/O error trotz einwandfreier Hardware gibt es 4 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Guten Tag,


    ich habe ein Blu-ray-Laufwerk von ASUS BW-16D1HT, welches seit einiger Zeit gar keine CDs, DVDs oder Blu-rays unter Opensuse 15.2 abspielen will. Vor ca. einem halben Jahr hat es noch funktioniert. Unter Win 10 auf dem selben Rechner funktioniert alles einwandfrei, ich kann alles was ich will abspielen, daher kann ich defekte Datenträger oder einen Defekt im Laufwerk selber ausschließen.

    In dmesg kriege ich beim Einlegen einer DVD u.a. folgende Meldungen:

    I/O error, dev sr0, sector 246268 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0

    Buffer I/O error on dev sr0, logical block 61567, async page read


    Die vollständige Ausgabe von dmesg: dmesg.txt

    Die Treffer bei google haben mich meist in die Richtung von schlecht gebrannten Scheiben geführt, was mir aber nicht weiterhilft. Ursprünglich hatte ich diese Anleitung hier befolgt, um auch kommerzielle Blu-rays abspielen zu können: https://wiki.archlinux.org/title/Blu-ray


    Hat einer von euch eine Idee, wie ich diesen Fehler beheben kann?

    Code
    uname -a
    Linux linux-maxim 5.3.18-lp152.78-default #1 SMP Tue Jun 1 14:53:21 UTC 2021 (556d823) x86_64 x86_64 x86_64 GNU/Linux


    Grüße, Eldrad

  • Ich kann mit der Meldung unter demesg jetzt leider nichts anfangen. Losgelöst von der Frage des Abspielens von kommerziellen Blue-Ray-DVDs - die hier schon aus rechtlichen Gründen nicht so ohne Weiteres erörtert werden sollte - stellt sich die Frage, ob auch nicht-kommerzielle Blue-Rays sich nicht abspielen lassen. Und dann stellt sich die weitergehende Frage, ob und gegebenenfalls was Du, wenn sich unter 15.2 bis vor einem halben Jahr noch hast abspielen können, Du in der Zwischenzeit an der Konfiguration geändert hast. Konntest Du auch damals schon alle Blue-Rays abspielen?

    Für den Inhalt des Beitrages 291712 haftet ausdrücklich der jeweilige Autor: matbhm

  • Schlüsselwörter in der dmesg sind "illigal request" und "without authentication".

    Für den Inhalt des Beitrages 291713 haftet ausdrücklich der jeweilige Autor: matbhm

  • Schlüsselwörter in der dmesg sind "illigal request" und "without authentication".

    Korrekt, und wir diskutieren in diesem Forum keinesfalls darüber, wie gängige Kopierschutz-Mechanismen umgangen werden können. Auch, wenn die DVD - oder Blue-Ray-Kopie rechtmäßig erworben wurde!

  • Und dann stellt sich die weitergehende Frage, ob und gegebenenfalls was Du, wenn sich unter 15.2 bis vor einem halben Jahr noch hast abspielen können, Du in der Zwischenzeit an der Konfiguration geändert hast.

    Danke, das war die richtige Frage, die mich zur Lösung gebracht hat. Da ich damals alle DVDs und Blu-rays abspielen konnte, musste sich ja was getan haben – ich hab mich dann erinnert, dass ich zwischenzeitlich das Upgrade von 15.1 auf 15.2 durchgeführt habe, wobei anscheinend libdvdcss2 verloren gegangen ist. Dieser Uralt-Thread hier hat mich wieder auf die richtige Fährte geführt: https://forums.opensuse.org/sh…5-DVD-s-not-playing-(some)


    Jetzt wird auch wieder alles so abgespielt, wie es soll.