Beiträge von Eldrad Ulthran

    Da der Rebuild der database nichts gebracht hat und sonst anscheinend nichts gegen den segfault hilft, hab ich in den sauren Apfel gebissen und eine De- mit anschließender Neuinstallation durchgeführt. Das ging ohne Probleme.

    Genau, auch auf dem Heimrechner das selbe Problem mit dem Publishing-Repo. Es liegt ja nicht an mir, dass das Repo mittlerweile eine unvollständige TeXLive-Installation anbietet :-/


    Das Repository "system package" bedeutet doch nur, dass das installierte Paket in keinem der aktivierten Repositories vorhanden ist, oder? Ich finde das erstmal nicht verwunderlich, da das texlive-Repo deaktiviert ist, der Downgrade aber noch nicht vollzogen wurde. Sind ja knapp 8000 Pakete^^


    Klar, eine Deinstallation und eine Neuinstallation von TeXLive ist mir auch schon in den Sinn gekommen, aber ich hatte gehofft, das auch mit einem Downgrade abschließen zu können.

    Ich sehe gerade, auf meinem Heimrechner (auch Leap 15.2) hab ich auch exakt das selbe Problem. Der Befehl aus Post #10 lässt sich nicht sinnvoll ausführen, das Auflösen der Abhängigkeitskonflikte endet ausschließlich in der kompletten Deinstallation von allem, was mit TexLive zu tun hat. Das Wiederherstellen der RPM database hat daran nichts geändert.

    Ich probiere das nächste Woche aus, wenn ich wieder auf der Arbeit bin. Aber wenn ich den Befehl richtig verstehe, soll die RPM database dann wiederhergestellt werden, wenn zypper gar nicht mehr funktioniert. Aber normale Updates können bei mir ganz normal installiert werden, z.B. über den Packagekit. Ich kann auch neue Pakete installieren. Einzig das Downgrade mit 8k betroffenen Paketen scheint zu viel auf einmal zu sein…

    Sorry, aber wenn ich Deine Repository-Zusammenstellung sehe, wird mir schlecht ... Sauerland wäre "not amused"!

    Hm? Gut, ich sehe jetzt auch, dass distribution/leap/15.2/repo/oss/ doppelt vorhanden ist (wahrscheinlich ein Überbleibsel vom Upgrade 15.1 → 15.2) und gelöscht werden kann, aber sonst?

    Und nach einem abgestürzten zypper-Aufruf kam folgende Meldung hinzu:

    Code
    dmesg | grep -E -i "error|fail|crit"
    [ 718.670403] zypper[2681]: segfault at 7f27dc4fb180 ip 00007f2d8b403d7a sp 00007ffecac9e900 error 6 in libzypp.so.1722.4.0[7f2d8af69000+5f8000]

    Bei journalctl kam nichts hinzu.

    Moin sterun,


    pdflatex und bibtex funktionieren tatsächlich noch einwandfrei, nur biber wegen falscher perl-Version nicht. Sehr gerne liefer ich die Infos, ich kann nur am Anfang immer schlecht abschätzen, was alles nützlich sein kann.

    Code
    rpm -qa zypper libzypp glibc
    zypper-1.14.45-lp152.2.24.1.x86_64
    libzypp-17.26.0-lp152.2.34.1.x86_64
    glibc-2.26-lp152.26.6.1.x86_64

    Erst mal die Meldungen nach einem sauberen boot ohne Versuch der Downgrade-Orgie:

    Code
    dmesg | grep -E -i "error|fail|crit"
    [ 0.260788] acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM
    [ 1.447548] RAS: Correctable Errors collector initialized.
    Code
    journalctl -b 0 -p err
    Jul 10 14:26:58 localhost kernel: usbhid 1-6:1.2: couldn't find an input interrupt endpoint
    Jul 10 14:26:58 localhost systemd-udevd[500]: Error calling EVIOCSKEYCODE on device node '/dev/input/event7' (scan code 0xc022d, key code 418): Invalid argument
    Jul 10 14:26:58 localhost systemd-udevd[500]: Error calling EVIOCSKEYCODE on device node '/dev/input/event7' (scan code 0xc022e, key code 419): Invalid argument
    Jul 10 14:27:05 localhost kernel: CIFS VFS: \\wfs-chemie.top.gwdg.de cannot query dirs between root and final path, enabling CIFS_MOUNT_USE_PREFIX_PATH
    Jul 10 14:27:15 localhost kwin_x11[1872]: kwin_xkbcommon: XKB: Key "<META>" added to modifier map for multiple modifiers; Using Mod4, ignoring Mod1
    Jul 10 14:27:15 localhost kwin_x11[1872]: kwin_xkbcommon: XKB: Symbol "Meta_L" added to modifier map for multiple modifiers; Using Mod4, ignoring Mod1
    Jul 10 14:27:16 localhost /hp-upgrade[1952]: hp-upgrade[1952]: error: HPLIP upgrade is disabled by openSUSE for security reasons, see https://bugzilla.novell.com/show_bug.cgi?id=853405 - if you like to upgrade HPLIP, use an openSUSE software package manager like YaST or zypper.

    zypper se -si | grep -Ei 'systemp|system-p|system_p|system p' erzeugt 8000 Zeilen Output, die sogar als Textdatei zu groß für einen Anhang sind. Fast alle davon sind texlive-Pakete, die ersten 20 Zeilen, die nicht zu texlive gehören, sind folgende:

    Code
    rpm -qa | grep zypper
    zypper-1.14.45-lp152.2.24.1.x86_64
    zypper-log-1.14.45-lp152.2.24.1.noarch
    zypper-lifecycle-plugin-0.6.1490613702.a925823-lp152.4.2.noarch
    zypper-needs-restarting-1.14.45-lp152.2.24.1.noarch
    Code
    uname -a
    Linux localhost 5.3.18-lp152.81-default #1 SMP Mon Jul 5 23:37:31 UTC 2021 (4022e93) x86_64 x86_64 x86_64 GNU/Linux
    Code
    df
    Filesystem 1K-blocks Used Available Use% Mounted on
    devtmpfs 3992788 0 3992788 0% /dev
    tmpfs 4003148 0 4003148 0% /dev/shm
    tmpfs 4003148 9856 3993292 1% /run
    tmpfs 4003148 0 4003148 0% /sys/fs/cgroup
    /dev/sda2 102687672 19920124 77508284 21% /
    /dev/sdb1 460441452 28201740 408780804 7% /home
    /dev/sda1 511720 152 511568 1% /boot/efi
    tmpfs 800628 16 800612 1% /run/user/1000

    Hallo,


    ich versuche gerade, meine unter Leap 15.2 etwas zerschossene TeXLive-Installation wieder zum Laufen zu bringen. Ich hatte zeitweise das Publishing-Repository eingebunden, aber dort wurde irgendwann das Paket perl-biber entfernt, und seitdem funktioniert biblatex/biber gar nicht mehr. Mein Ausweg wäre also, dieses Repo zu entfernen und auf die TeXLive-Version aus dem Hauptrepo zu downgraden.

    Beim Aufruf von

    Code
    zypper dup --allow-vendor-change --allow-downgrade

    wird ermittelt: 7 packages to upgrade, 6454 to downgrade, 93 new, 746 to remove, 6461 to change vendor.

    Wenn ich das dann bestätige, hängt sich zypper auf, es passiert nichts, und nach ca. 1 min wird es wegen segfault beendet. Die einzige Fehlermeldung, die ich in dmesg kriege, ist:

    segfault at […] error 6 in libzypp.so


    Ich habe versucht, den core dump nach dieser Anleitung hier zu speichern, habe aber nur eine unlesbare Binärdatei gekriegt https://www.suse.com/support/kb/doc/?id=000015982


    Während der Minute, die zypper "Dinge tut", sehe ich mittels free -m, dass die 8GB RAM komplett ausgenutzt sind und ca. 6GB geswapt werden.


    Hat einer von euch einen Vorschlag, wie ich den Downgrade durchziehen könnte?

    Und dann stellt sich die weitergehende Frage, ob und gegebenenfalls was Du, wenn sich unter 15.2 bis vor einem halben Jahr noch hast abspielen können, Du in der Zwischenzeit an der Konfiguration geändert hast.

    Danke, das war die richtige Frage, die mich zur Lösung gebracht hat. Da ich damals alle DVDs und Blu-rays abspielen konnte, musste sich ja was getan haben – ich hab mich dann erinnert, dass ich zwischenzeitlich das Upgrade von 15.1 auf 15.2 durchgeführt habe, wobei anscheinend libdvdcss2 verloren gegangen ist. Dieser Uralt-Thread hier hat mich wieder auf die richtige Fährte geführt: https://forums.opensuse.org/sh…5-DVD-s-not-playing-(some)


    Jetzt wird auch wieder alles so abgespielt, wie es soll.

    Guten Tag,


    ich habe ein Blu-ray-Laufwerk von ASUS BW-16D1HT, welches seit einiger Zeit gar keine CDs, DVDs oder Blu-rays unter Opensuse 15.2 abspielen will. Vor ca. einem halben Jahr hat es noch funktioniert. Unter Win 10 auf dem selben Rechner funktioniert alles einwandfrei, ich kann alles was ich will abspielen, daher kann ich defekte Datenträger oder einen Defekt im Laufwerk selber ausschließen.

    In dmesg kriege ich beim Einlegen einer DVD u.a. folgende Meldungen:

    I/O error, dev sr0, sector 246268 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0

    Buffer I/O error on dev sr0, logical block 61567, async page read


    Die vollständige Ausgabe von dmesg: dmesg.txt

    Die Treffer bei google haben mich meist in die Richtung von schlecht gebrannten Scheiben geführt, was mir aber nicht weiterhilft. Ursprünglich hatte ich diese Anleitung hier befolgt, um auch kommerzielle Blu-rays abspielen zu können: https://wiki.archlinux.org/title/Blu-ray


    Hat einer von euch eine Idee, wie ich diesen Fehler beheben kann?

    Code
    uname -a
    Linux linux-maxim 5.3.18-lp152.78-default #1 SMP Tue Jun 1 14:53:21 UTC 2021 (556d823) x86_64 x86_64 x86_64 GNU/Linux


    Grüße, Eldrad