Beiträge von Feli

    Ich kann ja den Gedanken/Wunsch nachvollziehen - hab das ja selber Anfang des Jahres gemacht.


    Allerdings war mein Rechner von Anfang an auf so eine Situation ausgelegt, sprich, meine Daten sind schon immer auf einer eigenen Partition und ich hatte noch ein bisschen freien Platz am Ende der Festplatte.

    Suse und *buntu zu mischen, halte ich für keine gute Idee - das "Warum" wurde dir bereits erläutert - aber ich empfehle dir, wenn es irgendwie möglich ist, das ganze nebeneinander einzurichten und dann schau erst mal, wie du mit Leap zurecht kommst.


    Frage: warum willst du Leap 15.3 nehmen und nicht 15.4?

    Ich würde mir kein System mit einem Plasma unterhalb von 5.24 installieren.

    Hi,

    os-prober ist weder die Ursache, noch die Lösung deines Problemes.


    Leap und Windows sind nicht im selben Modus installiert und darum kann os-prober das Windows nicht finden.


    Was tun?


    - alles lassen wie es ist und Windows über das Bootmenü des Rechners starten.


    - eines der beiden Systeme im Modus des anderen Systemes neu zu installieren.


    - Leap in eine Legacy-Version "umbauen", grob umrissen bedeutet das, in der /etc/fstab die Efi-partition auskommentieren und Grub in den MBR neu installieren. Ist aber nur Theorie, ich hab das bisher nur mal anders rum gemacht, also von "legacy" nach UEFI - und ja, geht nur mit einem Live-System, nicht aus dem laufenden System heraus.

    Dein Windows ist nicht im EFI-Modus installiert - wir können das nochmal kontrollieren, zeig bitte (als root) die Ausgabe von

    Code
    BOOT="/boot/efi";NAME="/EFI/Microsoft/Boot/bootmgfw.efi";UUID=$(sudo grub-probe -t fs_uuid "${BOOT}${NAME}");DEV=$(sudo grub-probe -t device "${BOOT}${NAME}"); { echo -e "\n# snip--->\nmenuentry \"Windows UEFI:  bootmgfw.efi $DEV\" {\n    search --fs-uuid --no-floppy --set=root $UUID\n    chainloader (\${root})$NAME\n}\n\n# <--- snip"  ;}

    Als Ergebnis sollte etwas in der Art kommen

    Code
    # snip--->
    menuentry "Windows UEFI:  bootmgfw.efi /dev/sda2" {
        search --fs-uuid --no-floppy --set=root B905-DA23
        chainloader (${root})/EFI/Microsoft/Boot/bootmgfw.efi
    }
    
    # <--- snip

    … mit blankem Home startet MV sofort. Es steckt also in meinem historischen Home irgendwas, was stört. Jetzt geht die Suche los.

    Ich würde das auch so interpretieren - viel Spaß bei der Suche nach "irgendwas".


    Aktuell habe ich gerade keine Idee, wo man da anfangen könnte - aber es ist auch spät und ich bin müde.


    So nebenbei, es würde mich schon irgendwie interessieren, wie die "alten Hasen" meine Vorgehensweise sehen? Passt das so, ist das "Suse-like"?

    Den Schlüssel hattest du importiert?


    Ansonsten kann ich zu meinem Leap nur sagen, es ist ziemlich jungfräulich, einzig opi codecs sowie ein zypper in lame flac vorbis-tools und natürlich sämtliche Aktualisierungen hatte ich vorher ausgeführt.

    Also ich hab unter Leap 15.4 einfach das RPM-Paket runter geladen, den Schlüssel importiert (als root)

    Code
    rpm --import https://download.mediathekview.de/stabil/MediathekView-rpm-signature-2021.pub

    und dann einen Klick auf das RPM-Paket gemacht und es wurde via Discover installiert - und ja, funktioniert.


    Ob das eine sinnvolle Vorgehensweise war, weiß ich nicht, Leap ist ganz neu für mich und es ist anders als Tumbleweed - aber es funktioniert. 😀