OpenGL für Intel-Grafikchipsatz installieren

Hinweis: In dem Thema OpenGL für Intel-Grafikchipsatz installieren gibt es 9 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Hallo zusammen,


    auf meiner Factoryinstallation wollte ich "Steam" installieren um eine Runde "Counterstrike" zu spielen. Ein SUSE-Paket habe ich leider nicht gefunden und so versuche ich eine Installation von Crossover 13.


    Allerdings bekomme ich in Crossover folgende Meldung:

    Zitat

    OpenGL funktioniert nicht: OpenGL hat in unseren einfachen Tests nicht funktioniert. Das bedeutet, dass OpenGL und DirectX Applikationen, inklusive der meisten Spiele, wahrscheinlich nicht funktionieren werden. Andere Applikationen sollten nicht betroffen sein.

    /sbin/lspci gibt bezüglich Grafikchipsatz folgende Ausgabe:


    Code
    00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)


    "glxgears" wollte ich auch schon aufrufen, aber das ist wohl nicht installiert. Welche Pakete muss ich nachrüsten?


    Beste Grüße,
    tapwag

  • Welche Pakete muss ich nachrüsten?


    Code
    zypper wp /usr/bin/glxgears
    Das Kommando 'what-provides' wurde durch 'search --provides --match-exact' ersetzt.
    Siehe 'help search' für alle verfügbaren Optionen.
    Daten des Repositories laden ...
    Installierte Pakete lesen ...
    S | Name | Zusammenfassung | Typ
    --+-------------+-----------------+------
    i | Mesa-demo-x | GLX-based demos | Paket


    Welcher Treiber bei Dir läuft, wurde ja bei lspci unterschlagen, daher:

    Code
    /sbin/lspci -nnk | grep -iA3 vga


    Ist opengl anstatt xrender in den Arbeitsflächeneffekten eingestellt?

    Für den Inhalt des Beitrages 71415 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Hallo Sauerland,


    danke für die schnelle Antwort. Hier nochmals die detaillierte Ausgabe von /sbin/lspci

    Zitat

    00:02.0 VGA compatible controller [0300]: Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 02)
    Subsystem: ASUSTeK Computer Inc. Device [1043:827a]
    Kernel driver in use: i915
    Kernel modules: i915

    Das Paket mesa-demo-x habe ich ebenfalls nachgerüstet, allerdings bekomme ich da folgende Ausgabe:

    Zitat

    mwagner@factory:~> glxgears
    Speicherzugriffsfehler

    Wie stelle ich openGL in den Arbeitsflächeneffekten ein? Ich verwende zur Zeit LXDE als Oberfläche, da KDE aktuell sehr langsam ist.

  • Poste einmal die komplette Repo-Liste:

    Code
    zypper lr -uP

    Für den Inhalt des Beitrages 71438 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Hallo Sauerland,


    hier die Ausgabe des Befehls.


  • Das Paket mesa-demo-x habe ich ebenfalls nachgerüstet, allerdings bekomme ich da folgende Ausgabe:




    Wie stelle ich openGL in den Arbeitsflächeneffekten ein? Ich verwende zur Zeit LXDE als Oberfläche, da KDE aktuell sehr langsam ist.


    Bugreports eröffnen?
    Der Intel Treiber läuft:

    Zitat

    Kernel driver in use: i915
    Kernel modules: i915

    Für den Inhalt des Beitrages 71443 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Installiere Dir mal das Paket

    Code
    inxi


    aus dem Packman Repository und rufe das mit dem Parameter

    Code
    -G


    auf. Eventuell gibt diese Ausgabe mehr Aufschluss, was da nun läuft und was nicht.