vuescan findet Netzwerk-Scanner nicht

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema vuescan findet Netzwerk-Scanner nicht gibt es 9 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • vuescan findet Netzwerk-Scanner nicht

    Hallo,

    ich habe unter Leap 15 (Gnome, 64 bit) heute vuescan (9.6.15.) installiert.Als Scanner verwende ich ein Multifunktionsgerät Canon Pixma MX925, das per LAN verbunden ist. Ich habe die von Canon gelieferten 64bit Treiber installiert und "scangearmp" funktioniert auch, findet also den Scanner. Das YAST Modul "Scanner" findet den scanner nicht und vuescan meldet auch das kein scanner gefunden wurde. Es gibt zwar Andeutungen bzgl. Verwendung als root, Firewall, Rechte für libusb aber so richtig beschrieben z.B. in einer Installationsanleitung ist das nicht. Daher meine Frage, ob hier jemand weiterhelfen kann.
    Der Druckerteil wird erkannt/funktioniert einwandfrei in Yast, CUPS, Turboprint, mit den Canon Treibern.

    Danke und Gruß, Erich

    Für den Inhalt des Beitrages 124621 haftet ausdrücklich der jeweilige Autor: erich_s

  • Canon Scanner = Canon Treiber.......
    Und damit funktioniert meist nur scangearmp.......

    Es sei denn, sie werden von sane unterstützt.
    Dann auch xsane usw.......
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 124622 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Hallo,

    das hat funktioniert, danke für den Hinweis. Ich hoffe ich habe mit "systemctl start firewalld.service" die Firewall wieder eingeschaltet (scheint so, danach findet vuescan den Scanner wieder nicht).
    Ich möchte nun nicht jedes Mal wenn ich was scannen will die Firewall abschalten, bleibt die Frage was muss in der Firewall konfiguriert werden, damit vuescan funktioniert?

    Danke und Gruß, Erich

    Für den Inhalt des Beitrages 124632 haftet ausdrücklich der jeweilige Autor: erich_s

  • Guckst du Handbuch Scanner.

    Oder nimmst lsof -i und guckst selbst, welche Ports das Ding einsetzt.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 124634 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Das Handbuch macht einen guten Eindruck und scheint sehr ausführlich zu sein, über die grundlegende Einrichtung steht da aber nichts (ist ja auch kein Installation Guide).
    lsof -i liefert zu vuescan leider überhaupt nichts.
    Mir gefällt vuescan aber wenn schon die Ersteinrichtung derart Probleme verursacht und der Hersteller, der ja auch nicht wenig Geld dafür haben will, keine Infos liefert muss ich wohl über Alternativen nachdenken. Kennt jemand welche?

    Danke und Gruß, Erich

    Für den Inhalt des Beitrages 124649 haftet ausdrücklich der jeweilige Autor: erich_s

  • soweit dein Scanner von sane unterstützt wird:
    xsane, skanlite und wie sie alle heissen.

    Wenn der Scanner nicht von sane unterstützt wird:
    scangearmp........

    Zum Thema vuescan und Port öffnen gibts im Netz genug Beiträge........
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 124652 haftet ausdrücklich der jeweilige Autor: Sauerland

  • ich lasse das mal gut sein

    Es gibt zahlreiche Artikel in denen es im Kern immer um Freischaltungen von Ports in der Firewall geht. Es gibt da aber keine einfache, allgemeingültige Antwort und die Beschreibungen passen auch nicht mehr zur neuen Firewall. Ich habe ja einen Workaround (Firewall abschalten) und irgendwann finde ich für mein System heraus was genau ich konfigurieren muss.

    Dana soweit und Grüße, Erich

    Für den Inhalt des Beitrages 124678 haftet ausdrücklich der jeweilige Autor: erich_s

  • lsof -i meldet selbstverständlich den korrekten Port. Man sollte halt nach dem eigentlichen Programm greppen.

    Wenn du das nicht hinkriegst, wäre es nach guter, alter Forums- Sitte sinnvoll, wenn du -statt falschen Unsinn zu plappern, posten würdest, welchen Befehl du __genau__ versucht hast, und was das Ergebnis davon war.

    Bei Druckern sind die Ports bekannt, da die entsprechenden Protokolle definiert sind.
    Bei Scannern treibt jeder Hersteller, was er will.

    Da wird man halt entweder das Handbuch lesen müssen (und sich ggf. das passende erst suchen und laden müssen),
    oder eben schlicht mit obigen Befehl nachgucken.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 124692 haftet ausdrücklich der jeweilige Autor: Berichtigung