Backintime - Mounten des Backupverzeichnisses schägt fehl

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Backintime - Mounten des Backupverzeichnisses schägt fehl gibt es 9 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Backintime - Mounten des Backupverzeichnisses schägt fehl

    Hallo,
    ich weiß jetzt nicht ob dieser Beitrag hier richtig ist, ein Forum für BackinTime habe ich allerdings nicht gefunden. Es geht darum, mit dem Tool Backintime mein Linux-System auf ein NAS (Synoloy Diskstation) zu sichern. Ich habe das konfiguriert wie hier beschrieben:
    Hardware Specific Setups · bit-team/backintime Wiki · GitHub

    Das passwortlose Login funktioniert mit Kommando "ssh bckoperator@nas-speicher (ich habe den user nicht "backup" genannt sondern "bckoperator") und über die grafische Oberfläche von Backintime. Bei Backintime gibt es allerdings die folgende Fehlermeldung

    Quellcode

    1. sshfs -p 22 -o ServerAliveInterval=240 -o IdentityFile=/home/erich/.ssh/bit28 -o idmap=user bckoperator@nas-speicher:./ /home/erich/.local/share/backintime/mnt/8114DE51/mountpoint kann nicht eingebunden werden
    und reproduziert durch Eingabe des Kommandos im Terminal:

    Quellcode

    1. erich@Linux-Desktop:~> sshfs -o sshfs_debug -p 22 -o ServerAliveInterval=240 -o IdentityFile=/home/erich/.ssh/bit28 -o idmap=user bckoperator@NAS-Speicher:./ /home/erich/.local/share/backintime/mnt/5EE0558C/mountpoint
    2. SSHFS version 2.9
    3. read: Connection reset by peer
    Backintime legt wohl unter /home/.local eine Verzeichnisstruktur an, das Gegenstück auf der Diskstation ist das home-Verzeichnis von bckoperator (/var/services/homes/bckoperator).

    Es gibt hierzu reichlich Diskussionen und auch Lösungen, z.B. hier: [Mint] Backintime mit rsync funktioniert nicht › Backups › System einrichten und verwalten › Systemverwaltung, Installation, Aktualisierung › Forum › ubuntuusers.de speziell die beiden letzten Beiträge vom Dezember 2017.
    Genützt hat mir das bisher nichts, daher bitte "HILFE".

    Meine Versionen:
    Diskstation DSM 6.2.1-23824 Update 6
    sshfs 2.9
    Backintime 1.1.24

    Danke und Gruß, Erich

    Für den Inhalt des Beitrages 132427 haftet ausdrücklich der jeweilige Autor: erich_s

  • erich_s schrieb:

    sshfs -p 22 -o ServerAliveInterval=240 -o IdentityFile=/home/erich/.ssh/bit28 -o idmap=user bckoperator@nas-speicher:./ /home/erich/.local/share/backintime/mnt/8114DE51/mountpoint kann nicht eingebunden werden
    Hinter dem Hostnamen mit dem Doppelpunkt (bckoperator@nas-speicher:) sollte dann auch ein Verzeichnis angegeben werden. Nur der Schrägstrich wäre das Wurzelverzeichnis deines NAS.
    Ist wirklich kein guter Mount-Punkt.
    Aber du hast ja ./ angegeben. Das wäre sozusagen ein verstecktes Wurzelverzeichnis. Und das gibt es nicht!
    Also, wo soll es auf dem Server hingemountet werden?

    Für den Inhalt des Beitrages 132435 haftet ausdrücklich der jeweilige Autor: ThomasS

  • Nein.

    Das ./ bezeichnet das Verzeichnis $HOME des angemeldeten Users, sonst nichts.
    Das ist schlicht die Spezifikation des URLs und dessen Implementierung in der SSH- Suite.

    Vor dem Doppelpunkt kommt der Hostteil (mit evtl. Usernamen samt Spasswort).
    Nach dem Doppelpunkt steht ein Pfad.
    Wird nichts angegeben, so meint das das $HOME Verzeichnis des Users dort.
    Folgt ein absoluter Pfad, so ist es der absolute Pfad auf dem Zielhost.
    Wird ein relativer Pfad angeben, so ist dieser Pfad relativ zum Homeverzeichnis dieses Users.
    Diese Pfadangabe ist überflüssig.

    Denn diese beiden URLs sind synonym:
    loser@someHost: und loser@someHost:./

    Die zweite Variante sagt schlicht: Im Home des Users "loser"s auf dem Host "someHost" das aktuelle (also HOME) Verzeichnis und dort das aktuelle Verzeichnis.
    Hendiadioyn.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 132436 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Berichtigung schrieb:

    Das ./ bezeichnet das Verzeichnis $HOME des angemeldeten Users, sonst nichts.
    Das ist schlicht die Spezifikation des URLs und dessen Implementierung in der SSH- Suite.
    Okay, das ist mir neu. Es trifft dann aber auch nur auf SSH zu, so wie du schreibst.
    Wie sähe es mit NFS aus? Denn damit habe ich versucht Parallelen zu ziehen.
    In der Manpage von SSHFS konnte ich dazu nichts finden...

    Für den Inhalt des Beitrages 132440 haftet ausdrücklich der jeweilige Autor: ThomasS

  • Jein.
    Es ist wirklich die Spec von URLs.
    (Und die gilt in vielen verschiedenen Kontexten)

    "Richtiger" ist, dass die Pfadangabe überflüssig ist.
    Da mittels eines relativen Pfades dasgleiche Verzeichnis bezeichnet wird, wie wenn man nichts angegeben hätte.
    Das einzige, was diese Pfadangabe bewirkt ist, dass das Parsen ein paar Nanosekunden länger dauert. (Und das fällt nun wirklich niemandem auf.)
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 132441 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Hallo,

    in den Anleitungen wird immer wieder gesagt, in Backintime soll die Pfadangabe leer gelassen werden weil es sonst nicht funktioniert, Das führt dann genau zu dem "bckoperator@nas-speicher:./ " (z.B. in der Anleitung bei GitHub Punkt 12). Außerdem wird in der gleichen Anleitung Punkt 6, erklärt, dass für sFTP das Home Verzeichnis des users bckoperator (wie der bei mir heißt) in der Diskstation gesetzt werden soll:
    On DSM 6 you can edit the user-root-dir for sFTP: Control Panel -> File Services -> FTP -> General -> Advanced Settings -> Security Settings -> Change user root directories -> Select User Now select the user backup and Change root directory to User home

    und für mich etwas verständlicher:
    Es liegt tatsächlich wie von <user> beschrieben an einer Rechte-Einstellung auf der Diskstation und zwar an den erweiterten FTP-Rechten - also Punkt 6 der Anleitung zu DSM 6. In der deutschsprachigen Benutzeroberfläche muss hier die Option "Benutzerbasis" ausgewählt werden wenn man den Eintrag für den Nutzer "backup" erstellt, so dass man dann einen Eintrag in der Liste erhält "Benutzer oder Gruppe" > "backup" und "Freigegebener Ordner" > "home".


    Kann man sshfs etwas mehr Debg Info entlocken? "-o sshfs_debug" hat nur zusätzlich die Versionsnummer ausgegeben.

    Gruß, Erich
    Ich kann mich nur an den Wochenenden mit dem Thema beschäftigen, bitte nicht wundern wenn's mal etwas dauert.

    Für den Inhalt des Beitrages 132453 haftet ausdrücklich der jeweilige Autor: erich_s

  • Du weisst aber auch, das das ein Problem der NAS ist.
    Bzw. ein Problem der Implementierung der Software auf dem Gerät, siehe die Beiträge mit /volume1/volume1 usw......
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 132458 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Ja, mir ist klar dass das mehr ein Thema des speziellen NAS Betriebssystems und von Backintime ist, ich würde das auch gerne wenigstens bei einem Backintime Forum einbringen habe bisher aber keines gefunden. Hier dachte ich, mehr über sshfs (z.B. debugging) zu erfahren. Ansonsten
    Yes Sir, gerne
    Gruß, Erich

    Für den Inhalt des Beitrages 132461 haftet ausdrücklich der jeweilige Autor: erich_s

  • Hallo,

    Das Hauptthema sind Einstellungen auf dem NAS. Ich habe das jetzt soweit geschafft, dass das passwortlose Login und das Mounten per sshfs funktionieren. Was noch nicht geht, ist der konkrete Backup mit rsyn, das bleibt an der Stelle einfach stehen (rsync -rtDHh --links --no-p --no-g --no-o --info=progress2 --no-i-r --rsh="ssh -p 22 -o IdentityFile=/home/erich/.ssh/bit28......). Dazu muss ich aber bei Backintime weitersuchen.

    Gruß, Erich

    Für den Inhalt des Beitrages 132709 haftet ausdrücklich der jeweilige Autor: erich_s