Upgrade von 15.1 auf Leap 15.2: Tastatur ohne AltGr und nach Neustart US-Layout

Hinweis: In dem Thema Upgrade von 15.1 auf Leap 15.2: Tastatur ohne AltGr und nach Neustart US-Layout gibt es 20 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo liebe Forengemeinde,


    nach dem Upgrade von Leap 15.1 auf Leap 15.2 habe ich ein Problem mit der Tastatur meines IBM IdeaPads G50-45 80E3 mit AMD A6-6310 APU. Das YAST-Modul Tastatur-Hardware & -belegung brachte mit keiner der generischen Tastaturen Abhilfe. AltGr besitzt keine Funktion und nach einem Neustart ist das Layout wieder amerikanisch.

    Das Upgrade mit zypper im runlevel 3 lief bis zu dem Punkt problemlos, bis ich bei den MS-TrueType-Fonts die Lizenzbedingungen angezeigt bekam und mit dem Drücken der Taste "q" die Anzeige beenden wollte. Ich landete direkt in der Kommandozeile und konnte wegen aktualisierter Bibliotheken nur noch reboot eingeben. Der Systemstart war unauffällig.

    Kann ich ggf. ein Paket neu installieren oder konfigurieren (analog zu dpkg-reconfigure) und die Einrichtung der Tastatur neu anstoßen?

    Ich danke für die Hilfe.

  • Unter...

    Code
    cat /etc/sysconfig/keyboard

    ...teste mal in der letzten Zeile:

    YAST_KEYBOARD="german,pc104"


    Poste auch mal die Ausgaben von:

    Code
    locale

    Und:

    Code
    localectl

    Kontrolliere auch:

    Anwendungsmenü - Systemeinstellungen - Eingabegeräte - Tastatur.

    Dort die "Voreinstellungen" wählen unter "Belegungen" und "Erweitert".


    Und auch mal prüfen, ob unter:

    Anwendungsmenü - Systemeinstellungen - Regionaleinstellungen "Deutsch" als "Bevorzugte Sprache" eingetragen ist.


    Ansonsten mal testweise einen neuen User anlegen und prüfen, ob es dort geht.

    2 Mal editiert, zuletzt von sterun ()

    Für den Inhalt des Beitrages 281697 haftet ausdrücklich der jeweilige Autor: sterun

  • Hallo sterun,

    danke für deine Antwort. Habe alle Systemeinstellungen geprüft, einen neuen Benutzer angelegt und einen Neustart durchgeführt. An der Konsole tty1 ist alles in Ordnung, in der Plasma-Sitzung besteht das Problem weiterhin. setxkbmap kommt immer erst einmal mit amerikanischer Tastatur ohne AltGR hoch. In evtest ist die Taste AltGr aber vorhanden.


    cat /etc/sysconfig/keyboard

    YAST_KEYBOARD="german-deadkey,pc104"

    locale

    LANG=de_DE.UTF-8

    LC_CTYPE="de_DE.UTF-8"

    LC_NUMERIC="de_DE.UTF-8"

    LC_TIME="de_DE.UTF-8"

    LC_COLLATE="de_DE.UTF-8"

    LC_MONETARY="de_DE.UTF-8"

    LC_MESSAGES="de_DE.UTF-8"

    LC_PAPER="de_DE.UTF-8"

    LC_NAME="de_DE.UTF-8"

    LC_ADDRESS="de_DE.UTF-8"

    LC_TELEPHONE="de_DE.UTF-8"

    LC_MEASUREMENT="de_DE.UTF-8"

    LC_IDENTIFICATION="de_DE.UTF-8"

    LC_ALL=

    localectl

    System Locale: LANG=de_DE.UTF-8

    VC Keymap: de-latin1

    X11 Layout: de

    X11 Model: pc105

    X11 Options: terminate:ctrl_alt_bksp

    setxkbmap -query

    rules: evdev

    model: pc105

    layout: us

    xmodmap -pk | grep -i ISO_Level3_Shift

    92 0xfe03 (ISO_Level3_Shift) 0x0000 (NoSymbol) 0xfe03 (ISO_Level3_Shift)

    108 0xfe03 (ISO_Level3_Shift) 0x0000 (NoSymbol) 0xfe03 (ISO_Level3_Shift)

    sudo evtest

    No device specified, trying to scan all of /dev/input/event*

    Available devices:

    /dev/input/event0: AT Translated Set 2 keyboard

    Event: time 1593854596.296767, type 4 (EV_MSC), code 4 (MSC_SCAN), value b8

    Event: time 1593854596.296767, type 1 (EV_KEY), code 100 (KEY_RIGHTALT), value 1


    Konsolenausgaben bitte in Code-Tags und nicht als Inline-Code!

    Für den Inhalt des Beitrages 281706 haftet ausdrücklich der jeweilige Autor: Schugy

  • 1. Yast - Hardware - System-Tastaturlayout = Deutsch?

    2. Yast - System - Sprache - Deutsch als Primäre und auch einzige Sprache?

    3. Und im selben Menü unter Details = Häkchen unter "UTF-8-Kodierung" und unter detaillierte Locale-Einstellung = "de_DE"?


    4. Anwendungsmenü - Systemeinstellungen - Regionaleinstellungen "Deutsch" als einzige Sprache?

    5. Anwendungsmenü - Systemeinstellungen - Eingabegeräte - Tastatur - Erweitert - Häkchen raus bei "Tastatureinstellungen ändern".


    6. Hast du die Möglichkeit, testweise eine USB-Tastatur anzuschließen - Problem auch dort?


    Abhängigkeiten ok:

    Code
    zypper ve

    Und was ergibt:

    Code
    zypper dup

    Und der Vollständigkeit halber:

    Code
    zypper lr -d

    Für den Inhalt des Beitrages 281735 haftet ausdrücklich der jeweilige Autor: sterun

  • Postest du noch zusätzlich die Ausgaben von:

    Code
    echo $XDG_SESSION_TYPE

    Und auch:

    Code
    update-alternatives --display default-displaymanager

    Für den Inhalt des Beitrages 281738 haftet ausdrücklich der jeweilige Autor: sterun

  • sterun

    Warum soll der User, der wohl scheinbar noch neu ist, eine Distributionsaktualisierung mit allen aktivierten Repos durchführen? Kennst du seine Repos? Ich halte dies für bedenklich.

  • Alero

    OK...

    Hätte ich detaillierter schreiben können.

    Bedingt durch ein vorheriges Dist-Upgrade wollte ich lediglich kontrollieren, ob weitere Pakete ausstehen / fehlen - ohne eine Installation anzustoßen.

    Deswegen schrieb ich extra "Und was ergibt: zypper dup".

    Schugy

    Bei zypper dup die Installationsbestätigung also mit [n] = nein ablehnen und falls vorhanden, nur die Ausgabe posten.

    Für den Inhalt des Beitrages 281744 haftet ausdrücklich der jeweilige Autor: sterun

  • Danke für Eure Antworten, hier die angeforderten Ausgaben:

    Code
    echo $XDG_SESSION_TYPE
    wayland