wie migriert man die Dateien einer virstuellen Maschine aus VMWare nach KVM

Hinweis: In dem Thema wie migriert man die Dateien einer virstuellen Maschine aus VMWare nach KVM gibt es 37 Antworten auf 4 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • ich habe diverse virtuelle Maschinen für Windows (W10 und W7). Diese sind unter VMware erstellt worden. Ich möchte diese nicht verlieren. Windows ist jeweils aktiviert. Ich würde sie gerne unter KVM weiterverwenden. Vmplayer ist nicht immer stabil

    Wie migriert man diese mit virt-v2v

    Ich versuche es mit virt-v2v -i vmx Windows10.vmx


    Fehlermeldung

    Code
    linux-Z840:/home/peter/Virtuelle Maschinen/Windows 10 x64 # virt-v2v -i vmx Windows\ 10\ x64.vmx
    [ 0.0] Opening the source -i vmx Windows 10 x64.vmx
    virt-v2v: error: source has no hard disks!

    Die virtuelle Maschine hat mehrer *.vmdk Files und virt-v2v findet diese nicht

    Wie nutzt man virt-v2v hier ?

    Für den Inhalt des Beitrages 288492 haftet ausdrücklich der jeweilige Autor: rebell21

  • Wie gesagt, VMWare nutze ich nicht...

    Aber zuerst musst du deine einzelnen VMWare-Files mit vmware-vdiskmanager zusammenführen.

    vmware-vdiskmanager -r mywin.vmdk -t 0 /tmp/mywin._combined.vmdk


    Danach kovertierst du dein *.vmdk zu qcow2.

    qemu-img convert -f vmdk -O qcow2 mywin._combined.vmdk mywin.qcow2


    Hier der Link:

    https://stafwag.github.io/blog…re-vrtual-machine-to-kvm/

    Für den Inhalt des Beitrages 288496 haftet ausdrücklich der jeweilige Autor: sterun

  • das habe ich nun so gemacht mit ein paar Problemen.


    Aber wie erzeugt man aus einer qcow2-Datei eine VM ?


    ich habe virt-manager gestartet und versucht, das Image zu importieren. Aber das hat nicht funktioniert.


    ich kann die Maschine nicht starten.


    Anbei ein Bildschirmfoto


    Unter VMware startete hier Windows 10


    Gibt es irgendwo ein Tutorial, um aus einer mit qemu-img erzeugten qcow2 Datei eine laufende VM für KVM zu machen ?

    Für den Inhalt des Beitrages 288512 haftet ausdrücklich der jeweilige Autor: rebell21

  • Ich kann auch keine neuen Virtuellen Maschinen aus einer Installations-CD oder einem ISO Image erstellen.


    Wenn ich eine CD einlege, kommt "Der Emulator besitzt keine Suchberechtigungen für den Pfad "/run/media/peter/WIN_7_ULTIMATE/setup.exe".


    Wenn ich ein ISO Image auswähle, kommt "Der Emulator besitzt keine Suchberechtigung für den Pfad "/run/media/peter/downloads/Microsoft/Win10_2004_German.iso"


    Ich kann also nicht von einer CD und auch nicht aus dem lokalen Filesystem installieren.


    Wenn ich ubuntu aus einen ISO-File installieren will, kommt "Der Emulator besitzt keine Suchberechtigung für den Pfad /run/media/peter/downloads/Linux"ubuntu-18.04.03-server-amd.iso"

    Für den Inhalt des Beitrages 288513 haftet ausdrücklich der jeweilige Autor: rebell21

  • Und was passiert, wenn du das ISO-File nach


    Code
    /home/peter/Downloads/

    kopierst?


    Code
    "/run/media/peter/downloads/Microsoft/Win10_2004_German.iso"

    scheint ja in einem Wechsellaufwerk zu sein.

  • Hallo,


    bei mir steht nicht das Einrichten einer neuen VM im Vordergrund. Ich nutze eine größere Windows 10 Vm in vmware. vmwareplayer ist aber nicht immer stabi. Manchmal dauert es Minuten, bis das Fenster wieder aktiv wird. Ich kann im Linux flüssig arbeiten, aber das Fenster von vmplayer antwortet nicht. Nach einigen Minuten geht es weiter. Daher möchte ich die Virtualisierzungssoftware wechseln. ich habe VirtualBox ausprobiert. Das funktioniert, ist aber nicht wirklich performant. Da fühlt sich Windows ganz zäh an. Obwohl ich der VM 28 (von 32) CPUs gegeben habe.

    Daher wollte ich auf KVM wechseln. Neuinstallation ist keine Alternative. Viele Programme sind installiert und W10 ist in dieser VM aktiviert. Daher wollte ich die VMDK Files der W10 VM aus vmware zu KVM migrieren.


    Dazu muss man die vmware Dateien zu KVM migrieren


    - vmware-vdiskmanager -r mywin.vmdk -t 0 /tmp/mywin._combined.vmdk - hat funktioniert. Ich habe eine einzige vmdk - Datei


    - qemu-img convert -f vmdk -O qcow2 mywin._combined.vmdk mywin.qcow2 - hat funktioniert. Ich konnte eine qcow2-Datei aus der vmdk Datei machen. Keine Fehlermeldung


    Ich kriege aber die qcow2 - Datei nicht in eine laufende Virtuelle Maschine unter KVM importiert.


    Weiß jemand weiter ?

    Für den Inhalt des Beitrages 288529 haftet ausdrücklich der jeweilige Autor: rebell21

  • - vmware-vdiskmanager -r mywin.vmdk -t 0 /tmp/mywin._combined.vmdk - hat funktioniert. Ich habe eine einzige vmdk - Datei

    Wichtig ist, dass in der Windows 10 VM "Schnellstart" vorher deaktiviert wurde - ansonsten kann es Probleme geben.


    Ich kriege aber die qcow2 - Datei nicht in eine laufende Virtuelle Maschine unter KVM importiert.


    Weiß jemand weiter ?

    Hast du den Link aus Post #2 abgearbeitet?

    Für den Inhalt des Beitrages 288530 haftet ausdrücklich der jeweilige Autor: sterun

  • Code
    virt-install --name "mywin" --ram 8192 --cpu host --os-variant win10 --vcpu 8 --disk /var/lib/libvirt/images/mywin_combined.qcow2,bus=ide --network bridge=virbr0 --import

    Mit virt-install kriege ich aus der *.qcow2 keine virtuelle Maschine erzeugt. Das Programm meldet, dass es das network device "bridge" nicht kennt. Außerdem kennt es den Parameter "bus=ide" nicht. Den habe ich durch "bus=sata" ersetzen können. Wenn ich das network komplett weglasse, meldet virt-install "Resource busy"


    ich habe dann den "virt-manager" genutzt. Der führt aber nur zu dem Ergebnis


    irgendwie kann das W10 nicht aus dieser qcow2 Datei starten.


    ich hatte vor dem Konvertieren der Dateien zu qcow2 die VM in vmware komplett gestoppt und heruntergefahren. Ich habe zwar keinen Schnellstart deaktiviert, allerdings auch nie genutzt. Sondern komplett gestoppt.

    Für den Inhalt des Beitrages 288531 haftet ausdrücklich der jeweilige Autor: rebell21

  • ich kann den Schnellstart in W10 in der in vmplayer laufenden Version von W10 überhaupt nicht aktivieren/deaktivieren. Es gibt den Menüeintrag Schnellstart dort überhaupt nicht

    Ich fahre die VM dann mal mit gedrückter Shift Taste herunter

    Für den Inhalt des Beitrages 288532 haftet ausdrücklich der jeweilige Autor: rebell21

  • Es gibt tatsächlich zwei Fehler, wenn man der Anleitung in Posting #2 folgt.


    1.

    Code
    ERROR Nicht unterstützte Konfiguration: IDE controllers are unsupported for this QEMU binary or machine type

    Dann wird da eben sata eingetragen


    2.

    Code
    ERROR Konnte Schnittstellen-MTU auf 'virbr0' nicht erhalten: Kein passendes Gerät gefunden

    Dann ändern wir virbr0 eben zu br0



    Der komplette Befehl:


    Code
    virt-install --name "WIN10_Trains" --ram 16384 --cpu host --os-variant win10 --vcpu 4 --disk /var/lib/libvirt/images/WIN10_Trains.qcow2,bus=sata --network bridge=br0 --import


    Und es läuft...


    Dateinamen, RAM sowie Anzahl Kerne halt noch anpassen :)

    Für den Inhalt des Beitrages 288533 haftet ausdrücklich der jeweilige Autor: Forentroll