[Gelöst]Netzwerkkarte Treiber nachinstallieren

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema [Gelöst]Netzwerkkarte Treiber nachinstallieren gibt es 9 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • [Gelöst]Netzwerkkarte Treiber nachinstallieren

    Hallo zusammen,

    Kurz zu meiner Situation: Ich habe OpenSUSE 12.1 parallel zu Windows 7 installiert. Hauptzweck für OpenSUSE ist experimentieren, evtl. ergibt sich später mehr. Daher kann ich auch kaum Kenntnisse bezüglich Bash & Co. vorweisen. Ich bitte, dies bei der Formulierung der Antworten zu berücksichtigen.

    Mein aktuelles Problem: Unter Windows funktioniert die Netzwerkkarte problemlos, unter Suse fehlen scheinbar die Treiber.

    Ich habe bereits in anderen Foren per Google gesucht, aber mein Problem leider noch nicht lösen können.

    laut lspci handelt es sich um eine Atheros Communications Device 1091 (rev 08)
    Nach einiger Recherche bin ich bereits darauf gestoßen, dass ein Treiber "ALX" passen würde, allerdings scheitere ich an der Installation desselben.

    OpenSUSE läuft bei mir unter 64bit, falls das etwas ändern sollte.

    Ich bedanke mich bereits im Voraus für Tipps und Ratschläge,

    Peter

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von LusH () aus folgendem Grund: Gelöst + Tags

    Für den Inhalt des Beitrages 45024 haftet ausdrücklich der jeweilige Autor: Busfanat

  • Hi Peter und willkommen hier im Forum.

    Kenntnisse bzgl. Bash brauchst du nicht, Du mußt nur wissen, wie man die Konsole/Terminal öffnet und die angeforderten Befehle eingeben und die Ausgabe hier in Code-Tags posten.

    Siehe auch meine Signatur.

    Poste bitte einmal als root die Ausgabe des folgenden Befehls:

    Quellcode

    1. lspci -nnk | grep -A 2 -i net


    Oder installiere (falls noch nicht geschehen) hwinfo und poste als User die Ausgabe des folgenden Befehls:

    Quellcode

    1. /usr/sbin/hwinfo --netcard


    Die Treiber sollten eigentlich im Kernel sein, Du brauchst normalerweise nichts herunterladen und installieren.
    Es sei denn die Hardware ist sehr neu.

    Gruß
    Sauerland
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Sauerland ()

    Für den Inhalt des Beitrages 45025 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Hallo,

    Erstmal Danke für die flotte Antwort.
    Wie lange die Netzwerkkarte bereits vertrieben wird, weiß ich nicht. Den Computer habe ich erst gestern gekauft. Ein Testen von OpenSUSE auf einem richtigen PC ist bisher gescheitert, weil OpenSUSE am vorherigen Rechner die Festplatte nicht erkannt hat und deshalb nicht installiert werden konnte... und auf virtuellen Maschinen kann Linux seine Stärken nicht ausspielen, weil Windows im Hintergrund ja Resourcen frisst... Aber das ist ja jetzt vorbei.

    Quellcode

    1. ...-OpenSUSE:/home/Peter # lspci -nnk | grep -A 2 -i net
    2. 03:00.0 Network controller [0280]: Ralink corp. RT5390 Wireless 802.11n 1T/1R PCIe [1814:5390]
    3. Subsystem: Ralink corp. Device [1814:f051]
    4. Kernel driver in use: rt2800pci
    5. 04:00.0 Ethernet controller [0200]: Atheros Communications Device [1969:1091] (rev 08)
    6. Subsystem: Hewlett-Packard Company Device [103c:2ad5]


    Quellcode

    1. -OpenSUSE:~> /usr/sbin/hwinfo --netcard
    2. 22: PCI 300.0: 0282 WLAN controller
    3. [Created at pci.319]
    4. Unique ID: y9sn.SEOF_CgF5w2
    5. Parent ID: QSNP.vzoHPYjXJ25
    6. SysFS ID: /devices/pci0000:00/0000:00:1c.4/0000:03:00.0
    7. SysFS BusID: 0000:03:00.0
    8. Hardware Class: network
    9. Model: "RaLink WLAN controller"
    10. Vendor: pci 0x1814 "RaLink"
    11. Device: pci 0x5390
    12. SubVendor: pci 0x1814 "RaLink"
    13. SubDevice: pci 0xf051
    14. Driver: "rt2800pci"
    15. Driver Modules: "rt2800pci"
    16. Device File: wlan0
    17. Features: WLAN
    18. Memory Range: 0xf7d00000-0xf7d0ffff (rw,non-prefetchable)
    19. IRQ: 16 (1995148 events)
    20. HW Address: 44:6d:57:80:a7:83
    21. Link detected: yes
    22. WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
    23. WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
    24. WLAN encryption modes: WEP40 WEP104 TKIP CCMP
    25. WLAN authentication modes: open sharedkey wpa-psk wpa-eap
    26. Module Alias: "pci:v00001814d00005390sv00001814sd0000F051bc02sc80i00"
    27. Driver Info #0:
    28. Driver Status: rt2800pci is active
    29. Driver Activation Cmd: "modprobe rt2800pci"
    30. Config Status: cfg=no, avail=yes, need=no, active=unknown
    31. Attached to: #14 (PCI bridge)
    32. 23: PCI 400.0: 0200 Ethernet controller
    33. [Created at pci.319]
    34. Unique ID: YmUS.KP2svJosAQ0
    35. Parent ID: HnsE.xohnMhyxMp5
    36. SysFS ID: /devices/pci0000:00/0000:00:1c.5/0000:04:00.0
    37. SysFS BusID: 0000:04:00.0
    38. Hardware Class: network
    39. Model: "Attansic Ethernet controller"
    40. Vendor: pci 0x1969 "Attansic Technology Corp."
    41. Device: pci 0x1091
    42. SubVendor: pci 0x103c "Hewlett-Packard Company"
    43. SubDevice: pci 0x2ad5
    44. Revision: 0x08
    45. Memory Range: 0xf7c00000-0xf7c3ffff (rw,non-prefetchable)
    46. I/O Ports: 0xd000-0xdfff (rw)
    47. IRQ: 10 (no events)
    48. Module Alias: "pci:v00001969d00001091sv0000103Csd00002AD5bc02sc00i00"
    49. Config Status: cfg=no, avail=yes, need=no, active=unknown
    50. Attached to: #15 (PCI bridge)
    Alles anzeigen


    zur Erklärung: aktuell habe ich meinen Laptop als WLAN-Hotspot laufen, damit ich über WLAN, das Gottseidank funktioniert, ins Netz kann, aber da ich keinen WLAN-Router im Netzwerk habe und meine Eltern auch keinen haben möchten, ist das Ziel, die LAN-Karte zu aktivieren.

    mfG,

    Peter

    Für den Inhalt des Beitrages 45026 haftet ausdrücklich der jeweilige Autor: Busfanat

  • Ist in compat-wireless:

    Quellcode

    1. modprobe -c | grep -i "1969.*1091"
    2. alias pci:v00001969d00001091sv*sd*bc*sc*i* alx

    Aber bitte vorher noch die Ausgabe des Befehls im Beitrag vorher.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 45028 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Hallo,

    Quellcode

    1. Linux Tower-Peter-OpenSUSE 3.1.10-1.16-desktop #1 SMP PREEMPT Wed Jun 27 05:21:40 UTC 2012 (d016078) x86_64 x86_64 x86_64 GNU/Linux


    das mit dem modprobe als su?

    Danke und mfG,

    Peter

    Für den Inhalt des Beitrages 45029 haftet ausdrücklich der jeweilige Autor: Busfanat

  • Nein, das mit modprobe zeigt nur, das die ID vom Kernel-Treiber alx unterstützt wird.

    Alles als root.
    Binde Dir dies Repo mit folgendem Befehl ein:

    Quellcode

    1. zypper ar -f http://download.opensuse.org/repositories/driver:/wireless/12.1-update/ compat-wireless-update

    Dann:

    Quellcode

    1. zypper ref

    Quellcode

    1. zypper in compat-wireless-kmp-desktop

    Quellcode

    1. rcnetwork restart


    Und die Karte sollte laufen, kannst Du mit

    Quellcode

    1. /usr/sbin/hwinfo --netcard

    nachschauen, dann sollte als Treiber alx erscheinen, wie bei der Ralink:
    Driver: "rt2800pci"
    Driver Modules: "rt2800pci"
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 45030 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Großartig 8)

    Danke für deine große Hilfe.

    Habs mit Yast gemacht, weil mir ein GUI lieber ist (Windoof-Loser ;) ), klappt aber hervorragend.
    Ganz ehrlich: So schnell hätte ich nicht mit einer Lösung gerechnet...

    ganz großes Danke,

    Peter

    Für den Inhalt des Beitrages 45032 haftet ausdrücklich der jeweilige Autor: Busfanat

  • Ich habe dir das ganze jetzt mal als Gelöst markiert, und passende Tags gesetzt.
    Wenn du in Zukunft einen Thread startest, setze bitte zu deinem Problem passende Tags.
    Die Tags werden von der Forensuche benötigt.
    Falls in Zukunft jemand dasselbe Problem hat kann er in der Forensuche danach suchen und sieht bereits deinen Beitrag, der ihm evtl. zur Lösung verhilft.
    ___________________________________________________________________________________
    Zypper Befehlsreferenz

    Für den Inhalt des Beitrages 45033 haftet ausdrücklich der jeweilige Autor: LusH