Tastatur springt nach jedem Neustart auf US zurück - nach Neuinstallation 15.2

Hinweis: In dem Thema Tastatur springt nach jedem Neustart auf US zurück - nach Neuinstallation 15.2 gibt es 27 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Ich habe in meinen Desktop PC eine neue Festplatte eingebaut und auf dieser Leap 15.2 neu von DVD installiert. Die Tastatur ist über USB angeschlossen. Ich habe bei der Installation deutsch eingestellt, Zeitzone, Sprache usw. Aber gleich beim ersten Start war trotzdem alles auf englisch/amerikanisch. Soweit alles inzwischen auf deutsch umgestellt, auch die Tastatur funktionierte mit deutscher Tastenbelegung - bis ich einen Neustart mache. Dann kommt statt "ü" wieder "[" usw.


    Wenn ich dann das grafische Yast öffne und gehe auf Hardware/System-Tastaturlayout, ist da entweder "Deutsch" eingestellt oder "Deutsch mit toten Tasten". Ich habe schon gelesen, dass man "Deutsch mit toten Tasten" wählen soll. Das Verrückte ist aber, ich brauche gar nichts einstellen, ich brauche auch nicht auf "Übernehmen" klicken, ich muss nur wieder zumachen, und die Tastatur funktioniert auf deutsch. Aber beim nächsten Neustart ist es wieder amerikanisch.

    Noch verrückter: wenn ich auf meinen zweiten User wechsle, ist die Tastatur dort gleich in deutsch. Wechsle ich zurück auf meinen Hauptuser, wo es eben noch amerikanisch war, ist es auf einmal, ohne dass ich da irgendwas gemacht habe, auch in deutsch. Allein durch Hin- und Herwechseln!


    Wo ich noch überall gespielt habe:

    Yast/System/Sprache Da steht als primäre Sprache Deutsch. Das Feld "Tastaturbelegung an Deutsch anpassen" ist mal ausgegraut, mal kann man da ein Häkchen setzen. Ich hatte nach vielen Neustarts und vielem Hin- und Her schon alles. Ist aber egal, was ich da einstelle, nach dem nächsten Neustart ist die Tastaturbelegung wieder amerikanisch.


    Dann war ich noch in Systemeinstellungen/Regionaleinstellungen. Da ist "Deutsch (Standard) eingestellt und nur das. Ich meine, dass da als zweite Sprache auch US-amerikanisch gewesen wäre, das habe ich aber entfernt. Hat aber keine Veränderung gebracht.


    Dann auf Systemeinstellungen/Hardware/Eingabegeräte ist unter dem Reiter "Belegungen" nur deutsch eingestellt. Unter dem Reiter "Erweitert" ist KEIN Häkchen bei "Tastatureinstellungen ändern"


    Ich habe schon in den einschlägigen Threads hier gelesen und poste daher noch folgende Konsolenausgaben:


    Code
    thomas@localhost:~> localectl
    System Locale: LANG=de_DE.UTF-8
    VC Keymap: de-latin1-nodeadkeys
    X11 Layout: de
    X11 Model: pc105
    X11 Variant: nodeadkeys
    X11 Options: terminate:ctrl_alt_bksp
    thomas@localhost:~>

    und:

    Soweit meine Fehlerbeschreibung und was ich schon versucht habe, jetzt bitte ich um Hilfe :-)

    Für den Inhalt des Beitrages 286913 haftet ausdrücklich der jeweilige Autor: tom2345

  • Vielen Dank schon mal, dass du dich des Problems annimmst. Leider scheint das aber noch nicht die Lösung zu sein, denn wenn ich das richtig sehe, ist das bei mir schon richtig:


    Code
    thomas@localhost:~> cat /etc/locale.conf
    LANG=de_DE.UTF-8
    thomas@localhost:~>

    Für den Inhalt des Beitrages 286918 haftet ausdrücklich der jeweilige Autor: tom2345

  • N'Abend,


    Also, wenn Dein anderer User die richtigen Einstellungen hat, dann wird der Fehler wohl nicht in der Systemebene liegen, sondern im Userbereich, sprich in Deinem Home- Verzeichnis. Geh mal kurz in Dich: hast Du irgendwelche Scripte am Laufen, die sich entfernt mit der Tastatur beschäftigen? Oder irgendwelche Übersetzertools? Halt irgendein Programm, was im Hintergrund an der Tastaturbelegung pfriemeln kann?


    Herzlichst, Gisela

    Für den Inhalt des Beitrages 286924 haftet ausdrücklich der jeweilige Autor: giff

  • Guten Abend Gisela,


    vielen Dank auch dir für das Beschäftigen mit meinem Problem!

    Ich habe definitiv keine Scripte am laufen, jedenfalls nicht bewusst. Übersetzertools benutze ich auch nicht. Um das auch ganz sicher zu verifizieren, werde ich nach dem nächsten Neustart erst mal top laufen lassen um zu sehen, ob mir da was auffällt.


    Was die Beobachtung angeht, dass beim zweiten User die Tastaturbelegung gleich stimmt, bin ich mir nicht sicher, ob das wirklich aussagekräftig ist in dem Sinne, dass das Problem auf der home-Ebene liegt. Weil, wenn ich dann vom zweiten User zum ersten User zurück wechsle, stimmt ja plötzlich die Tastatur auch beim ersten User - wie von Zauberhand.

    Wobei, auch das bringt mich auf eine Idee: ich könnte mal versuchen, gleich im zweiten User zu starten, um zu sehen, was dann passiert...


    Also zwei Ansätze, wenn auch nicht unbedingt aussichtsreich, aber Versuche wert!

    Ich werde berichten!

    Für den Inhalt des Beitrages 286926 haftet ausdrücklich der jeweilige Autor: tom2345

  • Nochmals guten Abend,


    Nach Rücksprache mit ein paar anderen Ideengebern:

    Bitte latin und alles was damit zu tun hat, sein lassen. Probier mal die erste Ausgabe von Dir so wie unten zu modifizieren.

    No-deadkey kannst Du dann immer noch einstellen, sobald latin weg ist...:


    Code
    localectl
    System Locale: LANG=de_DE.UTF-8
    VC Keymap: de
    X11 Layout: de
    X11 Model: pc105

    Als User folgendes ausführen:


    Code
    localectl set-keymap de-nodeadkeys


    Dann geht ein Fenster auf und fragt das Root- Passwort.


    Herzlichst, Gisela

    Einmal editiert, zuletzt von giff ()

    Für den Inhalt des Beitrages 286929 haftet ausdrücklich der jeweilige Autor: giff

  • Interessanter Hinweis, aber da muss ich jetzt dumm fragen: wo mache ich das? Wie komme ich an localectl?


    Edit: sorry, ich habe nicht tief genug gescrollt, du hattest mir ja schon beschrieben, was ich machen soll. Ich probiere es gleich aus!

    Für den Inhalt des Beitrages 286930 haftet ausdrücklich der jeweilige Autor: tom2345

  • Jetzt habe ich in der Aufregung den Befehl zuerst als root ausgeführt. Ich kann nur hoffen, dass da nichts kaputt gegangen ist.

    Als user habe ich es jetzt auch noch mal gemacht mit folgendem Ergebnis:

    Code
    thomas@localhost:~> localectl
    System Locale: LANG=de_DE.UTF-8
    VC Keymap: de-nodeadkeys
    X11 Layout: de
    X11 Model: microsoftpro
    X11 Variant: nodeadkeys
    X11 Options: terminate:ctrl_alt_bksp
    thomas@localhost:~>

    Ich mache jetzt mal einen Neustart und schaue, was passiert.

    Für den Inhalt des Beitrages 286933 haftet ausdrücklich der jeweilige Autor: tom2345

  • So, bin nach Neustart wieder da. Leider erst mal wieder die falsche Tastaturbelegung wie gehabt. Dann im Yast "System-Tastaturlayout" angeklickt, da war jetzt nicht mehr deutsch oben wie sonst immer, sondern englisch (GB). Deutsch mit toten Tasten angeklickt, jetzt stimmt die Tastatur wieder. Aber wahrscheinlich nur bis zum nächsten Neustart.

    Bei Top habe ich auch noch schnell geschaut, vor der Umstellung, aber mir ist nichts aufgefallen. Ich starte jetzt noch einmal neu.

    Für den Inhalt des Beitrages 286934 haftet ausdrücklich der jeweilige Autor: tom2345