OpenSUSE Tumbleweed und VMWare Player 15.1 - Probleme mit Module bauen

Hinweis: In dem Thema OpenSUSE Tumbleweed und VMWare Player 15.1 - Probleme mit Module bauen gibt es 15 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo!


    Da ich Pixinsight mir zulegen will, und dies leider erst ab glibc2.27 läuft, aber Leap 15.1 nur 2.26 unterstützt, habe ich auf Tumbleweed umgestellt. Leider Spielt VMWare da nicht mit.
    Maschine: Ryzen 9 3950, 32GB RAM, ASUS Prime X570-P, 2 NVME SSD.
    Kernel: 5.5.6-1-default, x86_64, KDE 5
    Das Thema ist IMHO nicht neu, ich hatte schon mal Probleme bei dem Umstieg auf Tumbleweed. Als Lösung ging es zurück auf eine Stable-Version.


    Jetzt hänge ich allerdings fest in einer Sackgasse. :(


    1. Geht es überhaupt, VMWare mit solch frischen Kerneln zum Laufen zubewegen?


    2. Wenn ja, hat einer eine Idee?


    Die Log-Files sind leider zu groß, um sie hier in voller Länge zu Posten.



    MfG Thomas

    System: Ryzen 9 3950X, 32GB RAM, ASUS PRIME X570-P, 2xPNY M.2 SSD 1TB, NVIDIA Quadro P2000
    :smilie_pc_012:

    Für den Inhalt des Beitrages 140357 haftet ausdrücklich der jeweilige Autor: steinsursel

  • Ich bin in den letzten Jahren immer wieder über Probleme bei der Installation von VMware gestolpert.


    Einmal funktionierte die Updatefunktion nicht, was sich durch die Installation der Pakete


    Code
    libncurses5
    pango
    pangox


    auch mit den 32-bit-Varianten beheben ließ.


    Neuerdings erscheint bei der Installation folgende Fehlermeldung:



    Code
    bora/lib/string/str.c:284 Buffer too small


    Abhilfe schafft die Installation mit folgender Befehlszeile:


    Code
    LC_ALL=C ./VMware-Player-15.5.0-14665864.x86_64.bundle

    Der Dateiname müsste dann eben noch angepasst werden.




    So, das waren meine 2 cent zu dem Thema, vielleicht hilfts ja.


    Beste Grüße,
    Stephan

    Für den Inhalt des Beitrages 140359 haftet ausdrücklich der jeweilige Autor: Forentroll

  • Was ich nicht verstehe, da Du ja den VMWare Player benutzen willst, mußt Du ja schon eine fertige Maschine als Datei haben. Warum dann unbedingt VMWare? Ich würde dafür VirtualBox nehmen.
    VirtualBox kann auch mit VMWare Dateien umgehen.

    Für den Inhalt des Beitrages 140362 haftet ausdrücklich der jeweilige Autor: Z_O_O_M

  • Hallo Stephan,


    aktuell helfen die Tips leider nicht. Ich erhalte immer noch beim Erstellen der Kernelmodule ein ExitCode=1.
    In den logs sind keine Errors auszumachen.


    Ich schaue und suche weiter ...


    MfG Thomas

    System: Ryzen 9 3950X, 32GB RAM, ASUS PRIME X570-P, 2xPNY M.2 SSD 1TB, NVIDIA Quadro P2000
    :smilie_pc_012:

    Für den Inhalt des Beitrages 140363 haftet ausdrücklich der jeweilige Autor: steinsursel

  • Was ich nicht verstehe, da Du ja den VMWare Player benutzen willst, mußt Du ja schon eine fertige Maschine als Datei haben. Warum dann unbedingt VMWare? Ich würde dafür VirtualBox nehmen.
    VirtualBox kann auch mit VMWare Dateien umgehen.

    Ich habe einige fertige Maschinen hier, Windows10 und einige Testumgebungen.
    Ich mache von denen erst mal ein Backup und probiere dann mal Virtualbox.

    System: Ryzen 9 3950X, 32GB RAM, ASUS PRIME X570-P, 2xPNY M.2 SSD 1TB, NVIDIA Quadro P2000
    :smilie_pc_012:

    Für den Inhalt des Beitrages 140365 haftet ausdrücklich der jeweilige Autor: steinsursel

  • @Z_O_O_M


    Mit VMware Player kann man sehr wohl VMs erstellen. Nur clonen geht nur in der kostenpflichtigen Version.


    Mit Virtualbox habe ich neulich schlechte Erfahrungen gemacht; die VMs liefen deutlich langsamer als jene mit VMware.


    Notfalls geht ja auch noch KVM/QEMU, was ich bei einem kurzen Test gar nicht mal so schlecht fand.





    Beste Grüße,
    Stephan

    Für den Inhalt des Beitrages 140366 haftet ausdrücklich der jeweilige Autor: Forentroll

  • Hallo!


    Tja, mit OpenBox erhalten ich nur fatale Fehlermeldungen:
    FATAL: INT18 Boot Failure oder man findet die Bootpartition nicht.
    Also wieder Bastelstunde ....


    MfG Thomas

    System: Ryzen 9 3950X, 32GB RAM, ASUS PRIME X570-P, 2xPNY M.2 SSD 1TB, NVIDIA Quadro P2000
    :smilie_pc_012:

    Für den Inhalt des Beitrages 140374 haftet ausdrücklich der jeweilige Autor: steinsursel

  • Hallo Thomas,
    installiere Qemu / KVM (ist einfach zu bedienen und extrem performant) - siehe hier:
    Qemu / KVM unter openSUSE Leap 15 installieren


    Mit convert kannst du deine Windows_10.vmdk in Qemu / KVM nutzen.
    ---Muss natürlich entsprechend deiner Umgebung leicht angepasst werden---

    Code
    qemu-img convert -f vmdk -O qcow2 win_10.vmdk win_10.qcow2

    Für den Inhalt des Beitrages 140376 haftet ausdrücklich der jeweilige Autor: sterun

  • Hallo!


    Danke für die Tips, aktuell bin ich mit Virtualbox unterwegs. Installiere eben alles neu, ist auch mal ein "Ausputzen".
    Die VMWare Daten fliegen nicht weg, sie liegen erst mal auf Eis.


    MfG Thomas

    System: Ryzen 9 3950X, 32GB RAM, ASUS PRIME X570-P, 2xPNY M.2 SSD 1TB, NVIDIA Quadro P2000
    :smilie_pc_012:

    Für den Inhalt des Beitrages 140393 haftet ausdrücklich der jeweilige Autor: steinsursel

  • Notfalls geht ja auch noch KVM/QEMU, was ich bei einem kurzen Test gar nicht mal so schlecht fand.

    KVM/Qemu ist nicht "notfalls", ist die erste Wahl unter Linux.
    Vollkommen quelloffen und sauschnell! (Sterun hat es mit performant umschrieben)


    Auf Grund der früheren Berichte hier bin ich von VirtualBox auf KVM/QEMU umgestiegen.
    Läuft wirklich schnell und stabil. Ich merke keinen Unterschied zwischen VM und realem PC.

    Für den Inhalt des Beitrages 140394 haftet ausdrücklich der jeweilige Autor: ThomasS