LEAP 15.2 Installation bleibt mit dunklem Bildschirm hängen

Hinweis: In dem Thema LEAP 15.2 Installation bleibt mit dunklem Bildschirm hängen gibt es 61 Antworten auf 7 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Was ist den hier die Definition von Nutzer?

    Ich nutze Leap als Betriebssystem und möchte mich eigentlich gar nicht mit den ganzen Details herum schlagen.


    Egal.


    Ich habe das Script jetzt in Autostart>Skriptdatei eingefügt.


    Das habe ich zunächst als root gemacht, mit der Einstellung Ausführung bei Start-up.

    Wenn ich mich dann als normaler User anmelde passiert nichts, d.h. die Auflösung ändert sich nicht.


    Dann habe ich das Script noch als user in Autostart>Skriptdatei eingetragen, mit der Einstellung bei Anmeldung.

    Der Restart verlief dann seltsam:

    - Direkt nach Anmeldung niedrige Auflösung.

    - Dann kurzes umschalten auf hohe Auflösung.

    - Danach wieder zurück schalten auf niedrige Auflösung.

    - Und zum Schluss startet des Dektop in niedriger Auflösung.


    Aus meiner Sicht wird da doch nach dem Script noch etwas Ausgeführt, was die Auflösung einstellt, oder?

    In der Autostart gibt es sonst keine weiteren Einträge.

    Für den Inhalt des Beitrages 290425 haftet ausdrücklich der jeweilige Autor: andy65

  • Update:


    Kein Restart sondern Rechner ganz aus und wieder an, dann funktioniert es.


    Ich schau mir das noch ein paarmal an, dann schließe ich den Beitrag.

    Für den Inhalt des Beitrages 290427 haftet ausdrücklich der jeweilige Autor: andy65

  • Was ist den hier die Definition von Nutzer?

    Das, was du in dein Profil geschrieben hast. Anfänger wissen das mit dem Autostart sicher nicht. Das ein Neustart zur Initialisierung des Scriptes nötig ist ... nun ja, schweigen wir darüber.

  • Ich hab dann mal meinen Wissensstand angepasst.


    Vielleicht kann mir noch einer der Wissenden erklären, warum das Skript

    in der Autostart eines normalen users funktioniert und in der Autostart vom

    root nicht.

    Für den Inhalt des Beitrages 290430 haftet ausdrücklich der jeweilige Autor: andy65

  • Vielleicht kann mir noch einer der Wissenden erklären, warum das Skript

    in der Autostart eines normalen users funktioniert und in der Autostart vom

    root nicht.

    Weil die Systemeinstellungen als "Root" ausgeführt für den User namens "Root" gültig sind. Systemeinstellungen als User, sind für DEN User, der sie tätigt. Möchte man, dass es für alle (zukünftigen) User ebenfalls angewandt wird, so kommt z.B. das Verz. "Skel" zum Einsatz. "Skel" wäre aber ein extra Thema ;-)

    Einmal editiert, zuletzt von sterun ()

    Für den Inhalt des Beitrages 290431 haftet ausdrücklich der jeweilige Autor: sterun

  • PS:

    Zeit zum Editieren des Posts war gerade abgelaufen.

    Wollte noch hinzufügen, dass es evtl. auch mit einem kleinen systemd Skript geht (Service Unit).

    Müsste man mal ausprobieren.

    Für den Inhalt des Beitrages 290432 haftet ausdrücklich der jeweilige Autor: sterun

  • Wie mein Vorposter schon in groben Zügen erklärte ist ein Eintrag im Autostart als User nur für den betreffenden User gültig. Root ist ein ganz anderes Benutzerkonto. De facto ein anderer User. Auch für einen neu angelegten User würde das Script also in dem Falle nicht greifen. Man müsste es also Systemübergreifend einsetzen. Aber das sprach mein Vorposter auch schon an. Dennoch behebt das Script nicht das Ursprungsproblem, da die Auflösung, wie von dir selbst berichtet, unter der 15.1 funktionierte.

  • Sorry, da habe ich mich nicht klar genug ausgedrückt.


    Ich habe das Skript als root in die Autostart des root eingetragen und

    als user in die Autostart des users.


    Also für beide Benutzerkonten separat.

    Für den Inhalt des Beitrages 290434 haftet ausdrücklich der jeweilige Autor: andy65

  • als user in die Autostart des users.

    Die einzelnen Befehle brauchen root Rechte, siehe Link in meinem Beitrag #16 oder Aleros im Beitrag #20.

    Das Script sollte auch root Rechte besitzen in deinem User Autostart Ordner.

    Die Rechtschreibfehler in diesem Beitrag sind nicht urheberrechtlich geschützt. Jeder der einen findet darf ihn behalten und in eigenen Werken weiterverwenden.

    Für den Inhalt des Beitrages 290441 haftet ausdrücklich der jeweilige Autor: Heinz-Peter