Kein Ethernet mehr nach Update von 15.1 -> 15.2

Hinweis: In dem Thema Kein Ethernet mehr nach Update von 15.1 -> 15.2 gibt es 16 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Ich sehe das zwar nicht als "mein" Problem, sondern als "update"-Problem...


    Ich probier's mal


    Gruß HeSta

    Nur mal zur Erklärung:

    Du hast den r8168 Treiber unter Leap 15.1 installiert und laufen lassen.

    Dazu gehört auch das blacklist.rpm.


    Nun machst du ein Upgrade zu Leap 15.2.

    Aber ohne den Treiber r8168 für Leap 15.2.

    Das blacklist.rpm ist aber immer noch installiert.


    Was macht jetzt dieses blacklist.rpm:

    Es hält den Treiber r8169 vom Start ab.

    Der Treiber r8168 ist aber für Leap 15.2 (bzw. dessen kernel) nicht installiert.....

    Somit für den Kernel von Leap 15.2 kein laufender Treiber für die Karte.......


    Nachtrag:

    Du hättest im Grub einfach den alten Kernel von Leap 15.1 auswählen können und Netzwerk wäre da gewesen.

    Dieser läuft auch unter Leap 15.2......


    Allerdings würde ich den deinstallieren, da ich den als störend empfinden würde.


    Und das ganze ist:

    PEBKAC


    Und von mir nicht böse gemeint, denn ich finde es gut, das du den Grund dann doch noch selbst herausgefunden hast.

  • Vielen Dank für deine Erklärung

    Zitat

    Du hast den r8168 Treiber unter Leap 15.1 installiert und laufen lassen.

    Ich habe KEINEN r8168-Treiber in 15.1 installiert. Die einzigen Treiber, die ich unter Opensuse seit Version 10 (oder so) installieren musste, waren Druckertreiber.

    Und ich muss auch sagen, ich bin froh darum, dass mir Opensuse abnimmt, den Netzwerktreiber, den Grafiktreiber, den HD-Controller-Treiber und was es noch alles für Treiber gibt, zu installieren. (Wenn ich mich um jeden Treiber kümmern wollte, würde ich zu ArchLinux wechseln. Nein, ich will es nicht.)


    Ich verstehe aber nicht, warum die Blacklist in 15.1 den Treiber bei 15.1 nicht geblacklistet hat, denn dort funktionierte ja das Netz. Warum erst nach dem Update?

    Aber ohne den Treiber r8168 für Leap 15.2.

    Ich kann mich nicht erinnern, dass ich beim Update angegeben hätte, den Treiber nicht zu updaten.

    Ich habe nur das blacklist- und das kmp-Paket deinstalliert und es funktioniert! Also muss der Treiber r8168 für 15.2 dagewesen sein.

    Ganz logisch finde ich das nicht.


    Nichtsdestotrotz habe ich wieder etwas gelernt!

    Viele Grüße und Danke für deine Geduld mit den PEBKAC-Leuten

    Für den Inhalt des Beitrages 282145 haftet ausdrücklich der jeweilige Autor: HeSta

  • Nein.

    Der Alternativ-Treiber r8168 (r8168-kmp-default) war für den Kernel aus Leap 15.1.

    Und somit unter Leap 15.1 installiert.

    Ob du das jetzt warst oder ob das automatisch geschehen ist sei dahingestellt.


    Dieser Treiber wurde nicht deinstalliert, da ja der Kernel aus Leap 15.1 auch nicht deinstalliert wurde.

    Dieser Treiber funktioniert aber nicht mit mit dem Kernel aus Leap 15.2 bzw. da fehlten Patches.

    Somit wurde der Treiber (rtl8169) aus dem Kernel benutzt.


    Aber:

    Da der Treiber r8168 nur funktioniert, wenn der rtl8169 Treiber nicht läuft, gibt es das blacklist.rpm (r8168-blacklist-r8169).

    Dies war natürlich auch noch installiert und machte, was es machen soll:

    den rtl8169 Treiber nicht laden.


    Somit würde der r8168 Treiber nicht geladen und der rtl8169 Treiber ebenfalls nicht und im Endergebnis:

    Netzwerkkarte funktioniert nicht, da kein Treiber.

  • Dieser Beitrag ist ein Paradebeispiel dafür, warum ich immer dafür plädiere, einen neue Version auf eine nackte Platte zu installieren und nicht als Upgrade über eine alte Version drüberzubügeln. Das kann gut gehen, bringt jedoch oftmals Probleme, die ich so nicht kenne.

  • Dieser Beitrag ist ein Paradebeispiel dafür, warum ich immer dafür plädiere, einen neue Version auf eine nackte Platte zu installieren und nicht als Upgrade über eine alte Version drüberzubügeln. Das kann gut gehen, bringt jedoch oftmals Probleme, die ich so nicht kenne.

    Hallo Alero,


    Jein...


    Seitdem diese Funktion vorhanden ist nutze ich dieses Feature von openSuse und kann nur sagen es funktioniert bisher fast immer. Egal ob ext3, ext4 oder btrfs.

    Die von Dir herbeigeredeten Probleme kenne ich seit Jahren nicht. Vielleicht benennst Du diese mal.


    Es gibt allerdings ein paar Regeln zu beachten:


    ► backup ist natürlich Pflicht


    ► kein verbasteltes System

    ► der Admin kennt das System selber schon länger

    ► keine 1-Clicker exoten

    ► alle Programme laufen ohne Probleme

    ► nur gut gepflegte aus offiziellen oder gut bekannten Repos

    ► alle updates der letzten Zeit sind ohne Probleme gelaufen

    ► das System selbst befindet sich im aktuellsten Stand

    ► das System selbst zeigt keine Hard- oder Software Probleme

    ► alle Repos außer den Standart Repos deaktivieren

    ► es muß genügend Platz auf der Root-Partition sein

    ► die LAN oder W-LAn Verbindung muß stabil funktionieren

    ► alle tmp-Verzeichnisse sollten geleert sein und alle gespeicherten *.rpms gelöscht sein

    ► es sollten keine properitären Treiber verwendet werden

    ► hybernate sollte deaktiviert sein

    ► System zum update temporär mit maximalem RAM bestücken

    ► extra home Partition muß vorhanden sein

    ► idealerweise nur 1 SSD / HDD intern angeschlossen

    ► alle externen Laufwerke müßen entfernt werden

    ► swap-Partition sollte mit ausreichender Größe gewählt sein

    ► nur Single-boot System kein Dual-boot

    ► externe prop Ton- und/oder Videokarten müßen entfernt werden

    ► Systeme mit mehreren Monitoren auf nur 1 Monitor (clone) stellen


    ... wer diese kleine Liste beherzigt dürfte keine Überraschungen erleben ...


    :)

    Für den Inhalt des Beitrages 282172 haftet ausdrücklich der jeweilige Autor: Petert

  • Vielleicht benennst Du diese mal.

    Warum? Hast du doch schon in deiner Liste getan. Denn wer "beherzigt" deine Liste? Wer?