Nach Installation von diffpdf funktioniert okular nicht mehr

Hinweis: In dem Thema Nach Installation von diffpdf funktioniert okular nicht mehr gibt es 36 Antworten auf 4 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo,


    ich habe ein OpenSUSE 15.2 (upgegradet von 15.1).

    Eben habe ich diffpdf 2.1.3.1 (über https://software.opensuse.org/…ffpdf?search_term=diffpdf, home:dliw) als 1-Klick-Installation installiert. Es wurden einige Konflikte gemeldet, für die allesamt für mich einleuchtende Lösungen angeboten wurden (normalerweise neuere Versionen "mit Anbieterwechsel"). Da ich damit in der Vergangenheit gute Erfahrungen gemacht hatte, habe ich es durchgezogen. Insgesamt mussten ca. 95 Pakete nachinstalliert werden.

    Seitdem funktioniert okular aber nicht mehr mit folgender Fehlermeldung:

    Code
    harders@lose:~> okular
    okular: symbol lookup error: /usr/lib64/libKF5XmlGui.so.5: undefined symbol: _ZN19KeySequenceRecorder16recordingChangedEv

    Ich habe okular nochmal deinstalliert und neu installiert, aber ohne Effekt.

    Ich habe dazu zwei Fragen:

    • Hätte zypper bzw. yast da nicht auf einen Konflikt zwischen okular und der neuen Library hinweisen müssen?
    • Habt ihr Ideen, was ich tun kann, um möglichst sowohl diffpdf als auch okular nutzen zu können? Falls nur eines der beiden geht, würde ich lieber okular weiternutzen.

    Bitte sagt mir, welche log-Dateien etc. ich posten soll.


    Viele Grüße und vielen Dank

    Harald

    Für den Inhalt des Beitrages 287865 haftet ausdrücklich der jeweilige Autor: harders

  • Welches Filesystem? Wenn du BTFS hast, wäre snapper rollback # dein Freund. Das Backup muß natürlich vor dem Zeitpunkt der Installation von diffpdf liegen.

    Ca. 95 Pakete nachinstallieren für so ein Progrämmchen? Scheint mir viel zu viel zu sein.

    Du hast doch nicht Tumbleweed ausgewählt? Es muß 15.2 sein.

    Für den Inhalt des Beitrages 287876 haftet ausdrücklich der jeweilige Autor: ThomasS

  • Poste bitte


    Code
    zypper lr -d

    Edit: Wenn du das Programm von hier >>> https://build.opensuse.org/package/show/home%3Adliw/diffpdf installiert hast, hast du Tumbleweed installiert, weil der Anbieter nur eine Tumbleweed Version im Angebot hat, das Leap ist geblockt.

    Da rate ich dir auch zu einem Snapper Rollback, denn jetzt hast du Tumbleweed mit Leap gemischt. Genau das führt zu Problemen.


    Edit: Inzwischen funktioniert die Leapversion wieder.

  • Danke euch!


    Leider habe ich ext4, so dass ein Rollback nicht möglich ist. Falls es dann keine Möglichkeit geben sollte, werde ich wohl mein Clonezilla-Update zurückspielen müssen, das ich vor meinem Upgrade von 15.1 auf 15.2 gemacht habe. Dann müsste ich halt alle Schritte für das Upgrade nochmal machen (inkl. anschließender Neuinstallation. Wäre nicht so schön...


    Ich habe die Version für Leap 15.2 installiert (https://software.opensuse.org/…Leap%3A15.2&query=diffpdf, siehe auch Screenshot). Wenn diese Version eigentlich für Tumbleweed ist, scheint die Blockierung für Leap nicht richtig gespeichert zu sein.


    Code
    harders@lose:~> zypper lr -d > zypper.txt
    harders@lose:~>

    Ich habe die Ausgabe in zypper.txt geschickt, weil das Einfügen der Ausgabe als Sourcecode die erlaubte Zeichenzahl für eine Nachricht gesprengt hat.

    Da haben sich eine ganze Menge Repositories angesammelt. Das kommt durch einige Programme, die in den Standard-Repositories nicht vorhanden sind. Liegt es vielleicht auch an der Vielzahl der Repositories? Habt ihr Empfehlungen, welche Repositories ich rausschmeißen sollte?


    Ich habe mittlerweile gemerkt, dass auch dolphin und kmix nicht mehr laufen. Das sind alles kde-Programme, oder? Anscheinend habe ich jetzt irgendwelche kde-Libraries zerschossen. Richtig?

  • Richtig. Bei der Repoliste wundert mich nur, das dein System bis jetzt überhaupt noch lief ...

    Ich geb dir mal was zum lesen...


    Über den Umgang mit openSUSE Repos

  • Wenn ich mir die Liste so anschaue, kannst du froh sein, dass da überhaupt noch was zuckt.


    15.1 und 15.2 Repositories gemischt und aktiv

    Home Repositories ohne Prioritäten eingebunden

    Qt Repository eingebunden => Probleme bei KDE vorprogrammiert, wenn man nicht weiss, was man tut


    Da geht eine Neuinstallation schneller, als das geradezubiegen.

    Da kommen sich garantiert auch noch einige configs ins Gehege.

  • Ich plädiere wie auch Trekkie00 für eine saubere !! Neuinstallation. Das System hast du gründlichst versaut.

  • moinmoin lieber Trekkie ,

    Wenn ich mir die Liste so anschaue, kannst du froh sein, dass da überhaupt noch was zuckt.


    15.1 und 15.2 Repositories gemischt und aktiv

    ... das ist der Beweis das openSUSE das "beste und stabilste Linux aller Zeiten" ist !! ;);)

    .. wenn das noch funktioniert ... allen Dank den "Paketbauern" !!!


    >> leider muß ich berichten, das ich auch schon mal so etwas ähnliches unter 13.xxx mir ansehen durfte .. Und es hat damals schon mehr als ein halbes Jahr lang "funktioniert" bis ich mal um Rat gefragt wurde ... Danach war mir klar wieviel besser SUSE ist ...

    Für den Inhalt des Beitrages 287957 haftet ausdrücklich der jeweilige Autor: Petert

  • Mein Vorschlag an den Fadenersteller wäre eine komplette Neuinstallation zu machen. Sollten dann einige Dinge nicht in den Standardrepositories sein, hier nachfragen. Kann man dann lösen.


    Und das Wichtigste :


    Finger weg von 1-Klickern !!!

    (ausser man hat Plan, von dem was man da tut)

  • Falls es dann keine Möglichkeit geben sollte, werde ich wohl mein Clonezilla-Update zurückspielen müssen, das ich vor meinem Upgrade von 15.1 auf 15.2 gemacht habe.

    Alero hat mich zwar heftig belehrt, dass ich keine Ratschläge zu einem anderen Vorgehen geben soll - wenn du also deine alte Version 15.1 mit Clonezilla zurückspielen willst, mach das so!




    Ich würde es anders machen!

    1. Eigene Daten per Backup sichern. (kein Image!)

    2. Neuinstalaltion

    3. Eigene Daten zurückspielen.


    Das geht in wenigen Minuten - auf jeden Fall unter einer Stunde. Wie lange bastelst du jetzt schon?

    Und es hat den Vorteil, dass du alten Ballast los bis, der sich immer ansammelt.


    Ich sage mir immer: Upgrade ja, wenn es klappt. Wenn nicht -> Neuinstallation.



    Aber nochmals: Ich möchte dir nicht abraten, ein altes Image einzuspielen!

    Wenn du das so willst, mach das so.



    _____________


    Meine zusätzliche Meinung (auch wenn es Alero mißfällt!):

    Images (sei es nun mit Clonezilla, dd oder sonst was - das Rollback von btrfs meine ich damit nicht!) nutzt man gerne als Microsoft-Windowsuser.

    Da mag es sinnvoll sein. Bei Linuxsystemen ist eigentlich ein Backup besser, weil schneller, platzsparender, flexibler........

    Ein Image ist nur sinnvoll, wenn man identische Computer haben will, warum auch immer. Du willst ja aber ein neueres System.